Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Search found 5 matches

by yudong123
November 29th, 2018, 2:25 pm
Forum: 2651A High Current SourceMeter
Topic: Error5028 when running the attached vi
Replies: 0
Views: 1829

Error5028 when running the attached vi

Hi guys, I have trouble running my vi that I attached when I set stop current as 50A. 2651A display error 5028. I could run it just fine when set the stop current as 20A. The vi basically run the script I wrote to run pulse current sweep and measure iv. But i dont think KIPulse factory function can ...
by yudong123
November 1st, 2018, 11:33 am
Forum: 2651A High Current SourceMeter
Topic: Measure diode at low current with pulse sweep Log
Replies: 2
Views: 2903

Re: Measure diode at low current with pulse sweep Log

Hi, Thank you very much for the reply!! I think that is exactly the issue of my setting. I went with SweepVLogMeasureI() function and result came back fine. However, lets say if I need to measure a sweep from 1 nA to 1 mA, the SweepVLogMeasureI() function will only define the i range once and it wil...
by yudong123
November 1st, 2018, 6:02 am
Forum: Test Script Builder
Topic: TSP Express with 2651A
Replies: 1
Views: 3568

Re: TSP Express with 2651A

Instead of trying to figure out TSP Express, I wrote a labview program using KI Pulse factory function and it turned out just fine. Still not sure why TSP Express wouldn't work. To those who have the same issue, try use use labview. Hope this helps!
by yudong123
October 31st, 2018, 2:46 pm
Forum: 2651A High Current SourceMeter
Topic: Measure diode at low current with pulse sweep Log
Replies: 2
Views: 2903

Measure diode at low current with pulse sweep Log

Hi, I am trying to measure a diode at low current range with 2651A. I am using KIPulse command from manual. f1, msg1 = ConfigPulseIMeasureVSweepLog(smua,0,1e-9,1e-6,1,0.0001,0.01,60,{v = smua.nvbuffer1, i = smua.nvbuffer2},1) The reading I got is a mess and current readings were totally wrong. I was...
by yudong123
August 27th, 2018, 11:01 am
Forum: Test Script Builder
Topic: TSP Express with 2651A
Replies: 1
Views: 3568

TSP Express with 2651A

Hi, I am trying to use TSP Express on 2651A to measure a power diode forward curve. My problem is that my measured data looks correct with DC sweep, but when I try to use Pulse mode I saw a great difference between source voltage and measured voltage. For example when I sweep from 0V to 3V the measu...

Go to advanced search