Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Search found 286 matches

by Dave W
January 14th, 2021, 9:01 am
Forum: Programming Support
Topic: TekScope Utility Bug Reports
Replies: 21
Views: 16311

Re: TekScope Utility Bug Reports

Hi Vic_Lai, Well that certainly is strange. Based on the screenshot you have taken I'm guessing by how the fonts in the title bars look that you are running on a display that has Windows DPI scaling set to something other than 100%. In version 1.3.0 there has been a lot of work under the hood to mod...
by Dave W
January 11th, 2021, 10:49 am
Forum: Programming Support
Topic: TekScope Utility Bug Reports
Replies: 21
Views: 16311

Re: TekScope Utility Bug Reports

Hi Lars. I don't have a TPS2000B to check it out. Can you capture an IO trace and send it to me? Start the capture before starting the data logger and let it capture a couple of cycles then stop it. That should hopefully give me enough information to see what is going on.
by Dave W
January 6th, 2021, 5:04 pm
Forum: Programming Support
Topic: Free Software: TekScope Utility
Replies: 6
Views: 18797

Re: Free Software: TekScope Utility

TekScope Utility 1.3.0 Released New version 1.3.0.0 of TekScope Utility has been released. This release includes the following changes: Added support for MSO6B Series oscilloscopes Added support for LPD64 digitizer Modified measurement fetching to ignore Windows localization settings. This avoids me...
by Dave W
October 7th, 2020, 9:10 am
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi gpetrowitsch. What the code is doing is trying to read the header information from the bitmap (.bmp) format image that the scope is sending. When serial port is used, the code uses the bmp format because the length is easily parsible to figure out how many bytes are expected. This is needed becau...
by Dave W
October 5th, 2020, 6:51 pm
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi gpetrowitsch. That is odd that the scope does not seem to be returning anything after sending HARDCOPY START. Perhaps there is some setting in the scope that's off in some way? Although I can't think of what. Below is the code that fetches the screenshot data for the TDS3K with the UI update code...
by Dave W
September 29th, 2020, 11:04 am
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Sounds like the scope is still responsive to front panel input. After the timeout occurs, can you try going over to the Waveform tab and see if you can fetch the waveform data? If TekScope Utility can establish a connection and fetch the waveform data then it seems that the timeout error is recovera...
by Dave W
September 28th, 2020, 4:45 pm
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi Wayne. Are you saying that after the timeout occurs, the scope freezes and you can't interact with it at all (remote or front panel) until you restart it?
by Dave W
September 21st, 2020, 5:11 pm
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi wclarke76. I know this may be a bit much to ask, but could you run the data logger again with NI IOTrace running and capturing the communications and then after the problem happens, save/export the trace to a .nitrace file so I can see more details about where the timeout is ocurring. I'm curious...
by Dave W
September 18th, 2020, 1:48 pm
Forum: General Discussion
Topic: Capture waveform screenshot from MDO3014 oscilloscope
Replies: 6
Views: 391

Re: Capture waveform screenshot from MDO3014 oscilloscope

Looking at your code there looks like a command syntax error in the second line. tekVISA.Write("SAVe:IMAGE FILEF BMP"); should read tekVISA.Write("SAVe:IMAGE:FILEF BMP"); If that command is not set correctly, the scope could be in a state where it doesn't know the desired format of hardcopy and so i...
by Dave W
September 18th, 2020, 9:54 am
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi cprijatel. There is a good chance that when TekVISA installed, it broke NI-VISA. You could try going into the NI Software manager and repairing the NI-VISA installation. If that doesn't work, then I would recommend a start over. Uninstall OpenChoice and TekVISA and uninstall NI-VISA as well. Rebo...
by Dave W
September 17th, 2020, 8:31 am
Forum: General Discussion
Topic: Capture waveform screenshot from MDO3014 oscilloscope
Replies: 6
Views: 391

Re: Capture waveform screenshot from MDO3014 oscilloscope

Hi venu13. It looks like you are using the TekVISANET library. You are using the incorrect read method from that library. The one you are using outputs the data as a string. You need to use the ReadBinary() method which outputs the data to an array of bytes (byte[]). Strings in C# are not the same a...
by Dave W
September 16th, 2020, 9:31 am
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi cprijatel, it sounds like you have both OpenChoice Desktop and TekScope Utility? My guess then is that you are experiencing a VISA conflict that needs to be resolved. OpenChoice Desktop installed TekVISA, but TekScope Utility relies on IVI VISA.NET library support which TekVISA does not have, thu...
by Dave W
September 10th, 2020, 1:51 pm
Forum: Programming Support
Topic: TekScope Utility Bug Reports
Replies: 21
Views: 16311

Re: TekScope Utility Bug Reports

Hi Sam. Sorry I haven't been available to respond earlier. Thank you for sending the trace. Looking at the trace I see that the measured value is coming back as 99.00000000000E+36 rather than an actual measurement value. This may be because the value is being fetched too early and for fetch delay is...
by Dave W
September 10th, 2020, 12:55 pm
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi dominik. Hmm, that definitely sounds odd. Would you be able to capture an IOTrace file of fetching the waveform data along with a screenshot of the scope and the saved .csv and send that to me vi private message? That will help me in determining what happened.
by Dave W
September 9th, 2020, 3:24 pm
Forum: Programming Support
Topic: Free Software: TekScope Utility
Replies: 6
Views: 18797

Re: Free Software: TekScope Utility

TekScope Utility 1.2.3 Released

New version 1.2.3.2 of TekScope Utility has been released. This maintenance release includes the following changes:
  • Added support for the new TBS1000C Series scopes
You can download this release from the post at the beginning of this thread.
by Dave W
August 24th, 2020, 10:34 am
Forum: Programming Support
Topic: TekScope Utility Bug Reports
Replies: 21
Views: 16311

Re: TekScope Utility Bug Reports

Hi Sam. Hmm... that sounds like the MSO5204B may not have measurement value available so it is returning values that are not numbers. Do you have NI IOTrace software? If you do, could you run IOTrace and capture the command traffic when this happens and then save the trace file and send it to me? Th...
by Dave W
August 10th, 2020, 6:08 pm
Forum: Programming Support
Topic: Free Software: TekScope Utility
Replies: 6
Views: 18797

Re: Free Software: TekScope Utility

TekScope Utility 1.2.2 Released New version 1.2.2.11 of TekScope Utility has been released. This maintenance release includes the following changes: Improved reliability when connecting/fetching data from 4 Series instruments. TekScope Utility will now retry connecting if a timeout occurs during th...
by Dave W
July 21st, 2020, 10:02 am
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

You don't specifically need NI-VISA, just a VISA that supports the IVI Standard VISA.NET interface. NI-VISA is what the program was developed using so I know it works, but in theory it should work with other vendor's VISA as long as VISA.NET is supported. For example, it should work with the latest ...
by Dave W
July 15th, 2020, 12:02 pm
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi Mark, You definitely have a VISA issue there which is common when you have more than one VISA installed (I have TekVISA and NI-VISA installed at the same time too so I've encountered some of these problems as well). I think what is happening is that NI-VISA is providing the VISA.NET interface tha...
by Dave W
June 29th, 2020, 2:44 pm
Forum: Programming Support
Topic: TekScope Utility Support
Replies: 60
Views: 18200

Re: TekScope Utility Support

Hi Garwing, You said your scope was a TBS1052B. Is this an EDU model or a non-EDU model? I see a note in the programmer's manual that that command is not supported on non-EDU models. If you have an EDU model then that would explain it. If this is the case, I thought I had taken care of that, but loo...

Go to advanced search