Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

ID CODE -113

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Post Reply
Nighthunter
Posts: 11
Joined: May 15th, 2011, 10:06 pm
Country: Slovenia

ID CODE -113

Post by Nighthunter » November 4th, 2011, 8:16 am

Hello,

I have a small problem.
I have making measurement with model 2400, but everytime I get a error -113 and I don't know what I'm doing wrong.

string send to Keithley is something like this:
:SENS:FUNC 'RES'
:SENS:RES:MODE MAN
:SENS:RES:OCOM ON
:SOUR:FUNC CURR
:SOUR:CURR 0.001
:SENS:VOLT:PROT 1
:SYST:RSEN ON
:OUTP ON

Thank you

Andrea C
Keithley Applications
Keithley Applications
Posts: 1390
Joined: October 15th, 2010, 10:35 am
Country: United States
Contact:

Re: ID CODE -113

Post by Andrea C » November 10th, 2011, 5:26 am

Hi Nighthunter,

The most common cause for a -113 error is a simply syntax problem.

I ran each of your commands to a 2400 and do not see any -113 troubles.
I did experience a -221 Settings conflict when sending the :SOUR:CURR 0.001 command. This is because the instrument is on a 100uA source range and the command is asking for 1mA of source current.

Can you single step through your program and isolate which command is the offender? You probably have a missing quote or something simple.

One suggestion: first send a *RST command to put the instrument into a known state.
When the instrument is in the *RST state, source auto range is enabled. This state then allows the instrument to automatically change to an appropriate source range for the :SOUR:CURR 0.001 command.

Andrea

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 4 guests