Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

RS232 to 2400 connection with Labview error 1073807346

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Post Reply
allse87
Posts: 9
Joined: February 10th, 2016, 10:54 pm
Country: Netherlands

RS232 to 2400 connection with Labview error 1073807346

Post by allse87 » February 10th, 2016, 11:38 pm

Hello,
I am trying to connect the 2400 using RS232 to use with Labview on my laptop. I have downloaded the NI drivers for the SMU. I use a RS232 to usb adapter cable with FTDI FT232R chip. My device is found with NI MAX (see screenshot image). I am trying to run the examples that come with the driver but always get an error message "Error -1073807346 occurred at VISA Write in Keithley 24XX.lvlib:Error Query.vi->Keithley 24XX.lvlib:Configure Measurement.vi->Keithley 24XX Read Single.vi". Once I run the VI the REM icon appears on the front panel display of the SMU. However once I get the error the SMU locks-up, none of the front buttons work, even when I unplug the RS232 cable, the SMU has to be restarted to get it to respond again.
The front panel screenshot of the VI is also shown, I have checked the RS232 settings on the instrument and that RS232 communication is selected.
Please help me to troubleshoot this problem, thanks.
Attachments
front panel.JPG
front panel.JPG (108.03 KiB) Viewed 20753 times
ni-max.JPG
ni-max.JPG (81.05 KiB) Viewed 20753 times

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: RS232 to 2400 connection with Labview error 1073807346

Post by Dale C » February 11th, 2016, 7:16 am

I believe this is a communication issue.
I would recommend to download the Keithley I/O Layer and install.
Here is the link.
http://www.tek.com/software/KIOL/850C07

Once that is done then go to the Keithley Config Panel.
Now enter in a new resource name for Com port 6.
Save it and try that.

allse87
Posts: 9
Joined: February 10th, 2016, 10:54 pm
Country: Netherlands

Re: RS232 to 2400 connection with Labview error 1073807346

Post by allse87 » February 12th, 2016, 1:38 am

Ok, I have downloaded the I/O. I got to the configuration panel but I am bot sure which name I need to change. I have tried to interface with the instrument using the communicator utility by selecting the instrument ASRL4::INSTR (P.S i changed the COM port to 4) and it seems to be working fine (ran few commands, did a remote measurement). However I can't get it to work with Labview, I tried to change the Alias for the VISA resource, and it changed in NI-MAX accordingly but I still get the error message.
Attachments
alias-change.JPG
alias-change.JPG (101.31 KiB) Viewed 20735 times

Andrea C
Keithley Applications
Keithley Applications
Posts: 1514
Joined: October 15th, 2010, 10:35 am
Country: United States
Contact:

Re: RS232 to 2400 connection with Labview error 1073807346

Post by Andrea C » February 12th, 2016, 4:41 am

On the 2400 and the configuration of the RS-232 communication, what is the Setting for the Terminator?

If you double click the KE24XX Initialize VI and examine the block diagram for the implementation, the Serial Interface is configured to use Line Feed as the TermChar.

Make sure that the Instrument and the software match.

allse87
Posts: 9
Joined: February 10th, 2016, 10:54 pm
Country: Netherlands

Re: RS232 to 2400 connection with Labview error 1073807346

Post by allse87 » February 14th, 2016, 4:56 pm

Andrea C wrote:On the 2400 and the configuration of the RS-232 communication, what is the Setting for the Terminator?

If you double click the KE24XX Initialize VI and examine the block diagram for the implementation, the Serial Interface is configured to use Line Feed at the TermChar.

Make sure that the Instrument and the software match.
Changing the Terminator to Line Feed (LF) has solved the problem, thank you. :)

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 1 guest