Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Windows10 driver for KUSB-488B USB to GPIB

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by Stuart M » October 30th, 2018, 10:41 am

Based on feedback we have found a problem in the Keithley KPCI-488LPA/KUSB-488B v3.13.1 driver installer when installed using the "Only for me" option.

Anyone who has installed with this option needs to uninstall the driver and then reinstall it using the "Anyone who uses this computer option". The problem is under investigation and a new version of the driver will need to be created, tested, and then released.

dcribeiro
Posts: 4
Joined: April 8th, 2019, 4:45 am
Country: Netherlands

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by dcribeiro » April 8th, 2019, 4:52 am

Dear Stuart,
We have in our lab a Keithley KUSB-488B. I have been trying to use it with a laptop in order to control a GPIB instrument. But I have been experiencing some issues as well.
I am running windows 10 64-bits, and I have tried both 3.13 and 3.13.1 driver versions. During installation, I have selected the ""Anyone who uses this computer" option, and the NI compatibility.

After the installation of the driver and after connecting the HW unit, I see the following driver error message on windows Device Manager:
KUSB-488B_device_manager.png
KUSB-488B_device_manager.png (16.74 KiB) Viewed 615 times
And nothing shows up on KEITHLEY GPIB configuration utility:
KUSB-488B_gpib_configuration.png
KUSB-488B_gpib_configuration.png (10.85 KiB) Viewed 615 times
Do you have any idea of what the problem might be?

Regards,
Diogo

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by Stuart M » April 9th, 2019, 2:01 pm

Never seen this problem before.
Has this system ever had a gpib driver on it prior to this recent install problem?
Can you try installing 3.13.1 on a different computer?

dcribeiro
Posts: 4
Joined: April 8th, 2019, 4:45 am
Country: Netherlands

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by dcribeiro » April 10th, 2019, 5:43 am

No, this computer was never connected to any other GPI-USB.
I have tried with two other computers and the behavior is the exact same.
Any other idea on what might be the issue?

Thank you for your help, Stuart.

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by Stuart M » April 12th, 2019, 11:43 am

Try the following to resolve your situation --

Remove KUSB-488B USB GPIB adaptor from host’s desktop/laptop USB ports, then uninstall the 3.13.1 driver.
With the KUSB-488B still disconnected reinstall the 3.13.1 driver.
Then, connect the KUSB-488B and see if the loader loads correctly.

If still having problems, reply/attach two system log files from your desktop/laptop:
C:\Windows\inf\setupapi.dev.log
C:\Windows\DPINST.log

That’s it.
Look forward to getting the feedback on your situation.

dcribeiro
Posts: 4
Joined: April 8th, 2019, 4:45 am
Country: Netherlands

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by dcribeiro » April 15th, 2019, 5:57 am

Hi Stuart,
That is the procedure that I have followed before. I have seen always the same error.
Attached follows those two files, from a clean installation of the driver on a different laptop (this one never went into the lab, and never had any kind of GPIB HW connected to it, yet the same error showed up).
Hope this helps tracking the problem.

Once again thank you for your help Stuart.
Regards,
Diogo

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by Stuart M » April 17th, 2019, 6:21 am

Hi Diogo,
Thanks for your very detailed reporting and troubleshooting.
According to the info in that log files you sent. Everything seems file with the installation of the 3.13.1 driver on your pc.
The problem we have noticed is a failure in startup of the KUSB-488B hardware loader in the device itself.
This seems to be an isolated malfunction in hardware. We have never seen this problem before but would like to analyze the device further.
Please return the hardware and report as a defective loader and request exchange for a new device.
Let me know if this corrects your problem there.
Best regards,
--Stuart

dcribeiro
Posts: 4
Joined: April 8th, 2019, 4:45 am
Country: Netherlands

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by dcribeiro » April 23rd, 2019, 12:43 am

Hi Stuart,
Once again thank you so much for your help.

Can you help me with one more thing?
In order to return the device, what procedure should I take and who should I contact?
(Sorry for posting this here, I tried to send you a PM, but I don't think it worked.)

Regards,
Diogo

Dale C
Keithley Applications
Keithley Applications
Posts: 2847
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Windows10 driver for KUSB-488B USB to GPIB

Post by Dale C » April 24th, 2019, 8:16 am

Hello Diogo,
Please call 503-627-2445/
that is the service department in Oregon.
They can help you return the unit for service.
Or go to this link.
https://www.tek.com/repair


Hope this helps.
Dale Cigoy

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 3 guests