Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

V-Source setting via GPIB-Labview

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Post Reply
[email protected]
Posts: 1
Joined: April 27th, 2018, 3:59 am
Country: Italy

V-Source setting via GPIB-Labview

Post by [email protected] » April 27th, 2018, 4:10 am

Hello,
I am using a Keithley SMU2420 to act as a current-limited voltage source to be controlled by a Labview application via GPIB.

I try to set, for instance: Vsource = 4.2V, Icompl = 0.15A giving these numbers in Labview.

The application correctly set the compliance current at 150mA (and all the other values required!), while the voltage is set to 4.0V. It seems that the instrument does not read any decimal. This happens trying to set ANY voltage in remote mode: it seems that the SMU accept only integer values.

In local mode, I can edit the value properly.

Could you help me?
Thank you.

Andrea C
Keithley Applications
Keithley Applications
Posts: 1263
Joined: October 15th, 2010, 10:35 am
Country: United States
Contact:

Re: V-Source setting via GPIB-Labview

Post by Andrea C » April 27th, 2018, 8:08 am

I suggest to invoke an NI IO Trace session to capture and inspect the actual ASCII commands sent to the 2420 by the LabVIEW program.
I suspect the LV code is somehow casting to an integer.
Also be aware that the 2420 will want dot as the decimal rather than comma.

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 3 guests