Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

sweep 1000 points with 1mS step

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Post Reply
xxnu1121
Posts: 3
Joined: June 1st, 2011, 7:17 am
Country: United States

sweep 1000 points with 1mS step

Post by xxnu1121 » June 1st, 2011, 7:33 am

I am using 2400. I'd like to source a waveform with 1000 points, and 1mS time between each point.
I already set NPLC to FAST mode 0.01, and source delay to 0, and line frequency to 60Hz. The total
time for the waveform is aournd 5S, rather than 0.01(NPLC)/60(Hz) *(1000 points) =1.6 S
How can I reduce the step and make the waveform run faster? Is it possible to source a waveform
with 1000 points and 1mS step? Like below?
waveform.JPG
waveform.JPG (10.81 KiB) Viewed 21064 times

Nathan S
Keithley Applications
Keithley Applications
Posts: 254
Joined: February 28th, 2011, 6:17 am
Country: United States
Contact:

Re: sweep 1000 points with 1mS step

Post by Nathan S » June 1st, 2011, 8:20 am

There will be very small overhead times between points so it may not be 100% able to get to that 1.6 s for the total sweep. However, a few tips to get closer:

-Make sure auto range is off for measure and sourcing. For measure, press the Auto button if the display shows AUTO in the top row. For the source ranging, hit Config then Sweep. Scroll over to Source-Ranging and hit enter. Select Best Fixed.
-Set source-measure delay to 0 by hitting config then the V button under source (middle of the top row). Scroll right to the next screen and select Delay and set that to 000.0000 s and hit enter. Then scroll right to auto delay and set that to disable.
-Next, ensure the filter is off by hitting Config then Filter. Scroll right to average-count and hit enter to select that. Set that to 1 reading and hit enter.

These are just a few steps that can hopefully reduce your overhead time and get you much closer to your desired speed. At that point it may be possible to play with delays if the steps are too close.

Hope this helps.

Nathan S
Keithley Applications
Keithley Applications
Posts: 254
Joined: February 28th, 2011, 6:17 am
Country: United States
Contact:

Re: sweep 1000 points with 1mS step

Post by Nathan S » June 1st, 2011, 8:32 am

Also, if you're just looking to source and not measure while sweeping, you can use the SCPI command :SENS:FUNC:OFF:ALL if using remote programming to disable all concurrent functions other than your V source sweep. :DISP:ENAB OFF should turn the front panel display off as well to add speed during the sweep.

xxnu1121
Posts: 3
Joined: June 1st, 2011, 7:17 am
Country: United States

Re: sweep 1000 points with 1mS step

Post by xxnu1121 » June 1st, 2011, 10:58 am

Thank you very much for your quick response. The lowest time duration for each step, by following those setting, is about 3.5mS. Is this the extreme value I can get? I saw an example - that 2400 generated 2.04mS "on time" voltage pulse with "non-pulse mode". Is it possible to further reduce the time duration for each step in custom type sweep?

Nathan S
Keithley Applications
Keithley Applications
Posts: 254
Joined: February 28th, 2011, 6:17 am
Country: United States
Contact:

Re: sweep 1000 points with 1mS step

Post by Nathan S » June 1st, 2011, 12:20 pm

Another possibility is to turn auto-zero off. This can be done on the front panel by hitting MENU ->scroll right to A/D-CTRL -> AUTO-ZERO -> disable and hit enter. By SCPI commands, this can be done by :SYST:AZER OFF .

Also, for speed, make sure source readback is off if you do choose to make current measurements during your sweep. You should be able to do this with :SENS:FUNC:CONC OFF and do this before setting up current readings if that is what you are measuring.

xxnu1121
Posts: 3
Joined: June 1st, 2011, 7:17 am
Country: United States

Re: sweep 1000 points with 1mS step

Post by xxnu1121 » June 2nd, 2011, 6:36 am

The NON AUOT-ZERO setting do help! I finally got the waveform for 1.3mS step. Awesome! Thank you, Nathan!

Nathan S wrote:Another possibility is to turn auto-zero off. This can be done on the front panel by hitting MENU ->scroll right to A/D-CTRL -> AUTO-ZERO -> disable and hit enter. By SCPI commands, this can be done by :SYST:AZER OFF .

Also, for speed, make sure source readback is off if you do choose to make current measurements during your sweep. You should be able to do this with :SENS:FUNC:CONC OFF and do this before setting up current readings if that is what you are measuring.

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 5 guests