Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

2400 controlled by LabVIEW: event structure

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Post Reply
santacruz
Posts: 3
Joined: November 8th, 2010, 9:54 pm
Country: United States

2400 controlled by LabVIEW: event structure

Post by santacruz » December 7th, 2010, 1:15 pm

Hi, I'm new to LabVIEW (version 2010), but I have been using a Keithley 2400 for a long time. I downloaded a Keithley example program from
http://www.keithley.com/base_download?dassetid=16128
which is supposed to sweep through voltage, measure current, and output the data to a file. My problem is that the program goes through the initialization step just fine, but it stops as soon as it reaches the Event Structure. At that point I have to abort. The data file never gets updated. I have also tried the Keithley example code which sweeps through current and measures voltage, but I get the same problem where the program initalizes and then stops (http://www.keithley.com/base_download?dassetid=16127). The example programs were made for LabVIEW 7, but I get no errors when my computer converts them to LabVIEW 2010. Can someone help me debug this, or provide documentation for those example codes? Thanks! :)

Tom Sw
Keithley Applications
Keithley Applications
Posts: 78
Joined: May 9th, 2010, 12:38 pm
Country: United States

Re: 2400 controlled by LabVIEW: event structure

Post by Tom Sw » December 7th, 2010, 5:24 pm

The NI website says this about opening VI's written in version 7 with 2010:

"The more recent versions of LabVIEW can open the VI. There is no guarantee that the VI will run properly without editing. Please check the upgrade notes for the version of LabVIEW you are trying to open the VI in for more information."

While I cannot promise, it could be that it just won't run properly in 2010.

santacruz
Posts: 3
Joined: November 8th, 2010, 9:54 pm
Country: United States

Re: 2400 controlled by LabVIEW: event structure

Post by santacruz » December 9th, 2010, 10:33 am

Thanks for the reply. I still am not able to get that code to work, except for the initialization step. I made a new program using the same initialization, and then I took the GPIB read/write commands that I needed from that program and was able to put together a working program. I'm still not sure what the problem was, but I think it's related to the event structure because that's where the program always stops.

existenz1982
Posts: 4
Joined: October 11th, 2010, 11:22 am
Country: United States

Re: 2400 controlled by LabVIEW: event structure

Post by existenz1982 » May 13th, 2011, 12:03 pm

Hi, I remotely control Keithley 2400 with LabVIEW and when I'm performing 4 point measurements I get different resistances for different currents. But when I'm measuring the same measurement with Keithley locally (not remote mode) I get the right values. For example if I measure resistor with 4 points, and switch the voltage sense between V+ & V- in local mode I will get same value with opposite sign, but in remote mode I will get positive different values in both cases.

Thanks,
Alex

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 1 guest