Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

unwanted infinite sweep with 2410

Models 2400, 2401, 2410, 2420, 2425, 2430, 2440, 6430
Post Reply
CyrilB
Posts: 1
Joined: September 6th, 2011, 9:26 am
Country: France

unwanted infinite sweep with 2410

Post by CyrilB » September 6th, 2011, 9:45 am

Hi,

In our lab, we have several 2410 SMUs that we drive using a "home-brew" software. With our most recent unit (bought last year, serial #1284998), I noticed a strange behaviour: it generates more sweep cycles than requested. At the beginning, it was doing two cycles, and now it is sweeping continuously, whatever we try (reboot, return to factory defaults...). This is not observed to a slightly older unit (approx 2 years old serial #1239497), which sweeps fine (i.e only once). Both units run the C30 firmware (in the menu, it says "Rev C30 Mar 17 2006... SCPI 1996.0 V:A02 A:H D:F").

The series of commands sent to the SMU is as follows:
*RST
:FORMat:SREGister ASCii
:ROUTe:TERMinals FRONt
:SOURce:FUNCtion:MODE VOLTage
:SOURce:VOLTage:STARt 0.0
:SOURce:VOLTage:STOP 10.0
:SOURce:SWEEp:RANGing AUTO
:SOURce:DELAy:AUTO ON
:ARM:COUNt 1
:SOURce:SWEEp:SPACing LINear
:SOURce:VOLTage:STEP 0.1
:TRIGger:COUNt 101
:SOURce:SWEep:POINts 101
:SOURce:VOLTage:MODE SWEep
:SOURce:SWEEp:DIREction UP
:SOURce:SWEEp:RANGing AUTO
*ESR?
0
:SENSe:AVERage:STATe OFF
:SYSTem:RSENse OFF
:SENSE:FUNCtion:CONCurrent ON
:SENSe:CURRent:NPLC 1
:SENSe:CURRent:RANGe:AUTO ON
:SENSe:CURRent:PROTection 0.0010
:SENSe:FUNCtion:ON "VOLTage:DC","CURRent:DC"
*ESR?
0

Then, I run the sweep with the following commands:

:STATus:QUEUe:CLEAr
:OUTPut ON
:INITiate:IMMediate
*ESR?
0
STATus:OPERation:CONDition?
8

Note that if I transfer the configuration via GPIB, but then run the sweep via the front panel, only one sweep cycle occurs.

Any idea what could cause such a difference in behaviour between 2410s? By the way, a difference I didn't think about is that the "faulty" SMU has an interlock cable connected (DB9 socket), while it is not configured for the other SMUs...

Regards

Cyril

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: unwanted infinite sweep with 2410

Post by Dale C » September 7th, 2011, 11:20 am

I am not sure what is going on with the extra sweeps.
I run your SCPI Command codes and only get one sweep.
This was performed on a C32 firmware revision.

Post Reply

Return to “2400 Series SourceMeter”

Who is online

Users browsing this forum: No registered users and 2 guests