Page 1 of 1

2230-30-1 vs. LabView 2011

Posted: January 29th, 2013, 5:23 am
by Flavio1976
when I try to set output voltage with the VI included in the "Native LabVIEW 2009 Instrument Driver version 1.2", I always get an error "150 - wrong number of parameters" and output voltage doesn't change. In other words, it seems there's a syntax error, or more likely the "driver" is not compatible with 2011 version.
:?: Anyone encountered this problem? :?:


Re: 2230-30-1 vs. LabView 2011

Posted: January 29th, 2013, 9:28 am
by Stuart M
I have tried both the Keithley KE22xx Series Monitor example
and the Configure and both seem to work for me in LV2012 with my model 2230.
Can you try both of these?

If this is still a problem exactly which VI are you having a problem with?
What OS and language do you have (e.g. win 7 32-bit)?
What version of LabVIEW 2012 (64-bit or 32-bit)?
What parameters did you change when using this vi?
Exactly what did you enter?

If you are entering numbers with comma separators this might explain your problem.
Try to enter decimals and see if this works any better.

How are you communicating with your instrument (usb or rs-232)?
Can you capture an IO Trace of this event and attach the problem?

Re: 2230-30-1 vs. LabView 2011

Posted: January 29th, 2013, 11:44 pm
by Flavio1976
Hi Stuart, thanks for the answer.

In the meanwhile I tried the driver for the 2200 (that works for channel #1 with the 2230). In the block that assemble the command string, I saw there's a "%.;" before the floating type declaration, that actually override my windows' setting for decimal separator (comma... :roll: )!
Now my "official" Keitlhey driver is modified in that way to be comma-separator-proof.
HTH other users, thank You again.