Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Error : Illegal value for parameter #7

Post Reply
Taeho Kim
Posts: 1
Joined: August 13th, 2018, 6:50 pm
Country: South Korea

Error : Illegal value for parameter #7

Post by Taeho Kim » August 13th, 2018, 7:27 pm

When I use "PMU_SegArb_Example" in the user modules, I have entered all the values correctly in the Ch1 and Ch2 Segment ARB Definitions, but the pulse is not applied with the message "seg_arb_sequence (): Illegal value for parameter # 7". I don't know at what step I entered the wrong parameters.
Can you give me a description of each parameter (Seg TrigOut, SSRCtrlCh1, etc.) in "Seg ARB Segments and Sequences"?
Or can you give me any tips when I using 'PMU_SegArb_Example' to run arbitrary pulses and measurements at the same time?

Brad O
Keithley
Keithley
Posts: 28
Joined: February 3rd, 2018, 10:43 am
Country: United States

Re: Error : Illegal value for parameter #7

Post by Brad O » August 14th, 2018, 8:38 am

Hi Taeho,

That error is telling you there is something wrong with the SegTime settings in either your Ch1 or Ch2 Configurations.

You can see more information on the function giving this error if you search "seg_arb_sequence" in the Reference Manual. It's reference page gives full descriptions over all its inputs, though you can't directly edit many of them in the PMU_SegArb_Example user module. For the ones you can edit:
StartV and StopV are where the pulse segment will start and stop obviously.
SegTime is the duration of the pulse segment
SegTrigOut sets the TTL level of the output trigger
SSRCtrlCh# sets the output relay on or off, a value of 0 disconnects the PMU channel output so that no pulse will be seen on that channel for that segement

If you still get the error, can you also post the number that the test returns to the results? And you are able to run the default settings of the test, right?

Post Reply

Return to “4200-SCS Semiconductor Parameter Analyzer”

Who is online

Users browsing this forum: No registered users and 2 guests