Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

2450 NPLC and measurement time discrepancy

Models 2450, 2460, 2461, 2470
Post Reply
hiarashi
Posts: 6
Joined: June 15th, 2016, 2:16 am
Country: Finland

2450 NPLC and measurement time discrepancy

Post by hiarashi » August 3rd, 2021, 7:23 am

A strange thing I noticed about the SMU we have in use. NPLC doesn't seem to correspond to the timing between measurements as stated in the manual.

If I set NPLC to 1, I get measurements every 0.04 s, as opposed to 0.02 s as expected, unless there's something I'm missing. Operating in a 50 Hz network, so by my reckoning 1 PLC is 1/50 = 0.02 (s). At first I thought maybe the setting is not actually getting set, although the front panel was showing NPLC 1, but furthermore setting it to 0.5 changed the timing to 0.02 s, oddly. The same with setting NPLC to 2, the time between measurement points is 0.08 s.

Seeing that it's always double had me pondering, whether I'm missing something obvious, but I just can't find anything and am not setting anything that should have such an effect as far as I know.

Andrea C
Keithley Applications
Keithley Applications
Posts: 1601
Joined: October 15th, 2010, 10:35 am
Country: United States
Contact:

Re: 2450 NPLC and measurement time discrepancy

Post by Andrea C » August 3rd, 2021, 3:03 pm

In the menu, check the Settings in the Source column. Source read back is on by default which is accounting for the x2 extra time.

hiarashi
Posts: 6
Joined: June 15th, 2016, 2:16 am
Country: Finland

Re: 2450 NPLC and measurement time discrepancy

Post by hiarashi » August 5th, 2021, 1:39 am

Thank you, that makes sense.

Post Reply

Return to “2450/2460/2461/2470 Touchscreen SourceMeter”

Who is online

Users browsing this forum: No registered users and 1 guest