Model 2000 RS232 not sending data

2000, 2001, 2002, 2010, 2100, 2110
Post Reply
Light Jet
Posts: 2
Joined: October 3rd, 2015, 4:06 am
Country: Estonia

Model 2000 RS232 not sending data

Post by Light Jet » October 3rd, 2015, 4:58 am

i have problem with model 2000 using RS232.
It acts correctly to all my commands, except those when it must write something back.
I'm using 1:1 cable with usb to serial adapter.
I've used putty terminal program to connect with it and same results as using PySerial.
Device do not answer even command *IDN?
Measurement values comes to device screen, but nothing is sent to the serial, at least putty can't read anything, while i was testing.
Hope some1 has idea what's going on with my device.

i try measure 9V battery on 10VDC range and slow mode.

Code i'm trying to use:

Code: Select all

*rst; *CLS
wait 1.5 s
:system:azero:state off
wait 1.5 s
:volt:dc:nplc 10; :volt:dc:dig 7
wait 1.5 s
:VOLT:DC:RANGe:UPPer 10
wait 1.5 s
:volt:dc:average:state off
wait 1.5 s
:trigger:delay 0.0
wait 1.5 s
:read?
i tried also fetch and measure commands.
most of the code is from the forum.

Input is 220V, 50Hz
adapters:
1) U232-P9
2)http://www.hardware.am/Photo/Products/N ... verter.jpg

p.s. i've tried auto modes and config it by using examples, nothing works.
Tried different rates, nplc, dig values, baud, flow, terminator options.
Changed USB to serial adapters and used different usb ports.
Tried front and back connectors of the 2000.

Best regards
Kristjan Nurmela

Andrea C
Keithley Applications
Keithley Applications
Posts: 1167
Joined: October 15th, 2010, 10:35 am
Country: United States
Contact:

Re: Model 2000 RS232 not sending data

Post by Andrea C » October 3rd, 2015, 1:30 pm

Kristjan,

When you send it a command, does the 2000 display REM indicator on the front panel?

The USB to RS-232 product you indicate, most likely uses a Prolific driver. Check your Windows Device Manager and verify that Windows is happy with the installation of the device and confirm which COMx port number is assigned to it.

Using PuTTY utility software with Serial connection type and with settings:
baud=9600
data bits=8
stop bits = 1
parity = none
flow control=XON/XOFF

Instrument settings (Shift>RS232)
RS232: ON
Baud: 9600
Flow: XonXoff
TX Term: CR

Focus on testing the communication using the *idn? command and reading back the response string.

Andrea

Light Jet
Posts: 2
Joined: October 3rd, 2015, 4:06 am
Country: Estonia

Re: Model 2000 RS232 not sending data

Post by Light Jet » October 4th, 2015, 5:06 am

thanks Andrea,

i figure it out.
I had 2 problems
1) i didn't close serial in the end of the program
2) seems my 2000 has some serial problems inside, because i could talk to another 2000 with no problems at all.

Post Reply

Return to “Series 2000 and Series 2100 DMM's”

Who is online

Users browsing this forum: No registered users and 1 guest