Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Model 2002 / KUSB-488B Driver Issue

2000, 2001, 2002, 2010, 2100, 2110
Post Reply
CalibratorFloppy
Posts: 2
Joined: November 22nd, 2016, 4:31 am
Country: Germany

Model 2002 / KUSB-488B Driver Issue

Post by CalibratorFloppy » November 22nd, 2016, 6:22 am

Hello,

i think i have a serious driver issue with the KUSB-488B GBIP Adapter.

prior to my problem description, my environmental data:

OS: Windows 10 Pro

GPIB-Adapter: KUSB-488B (VID:05E6, PID:488B)

Driver: SCPI Command Compatible One
Driver-Version: 7.0.2.1117 (as stated in Device Manager)
Driver-Date: 17.11.2014

IDE-Platform: c# / Visual Studio 2015

Indicated Problem: Blue Screen (BSOD) / Source: usbxhci.sys

We developed a multi-device calibration Software which utilizes your Model 2002
for reference Measurements and several other devices as DUT's,
here especially mentioned several PXI-Measurement Cards from National Instruments within a PXI Chassis
which are connected via ExpressCard Bus and a Controller within that Chassis.

The Software uses Threading and works fine and stable whenever i only use one of the instrument interface-types.
But whenever i try to access both in parallel i have a BSOD occuring randomly.
The Blue Screen tells there is an IRQL_NOT_LESS_OR_EQUAL - Error caused by the File usbxhci.sys which is the
driver for the USB 3.0 extensible Host controller.

Whenever i only use the Model 2002 via GPIB Adapter alone or in parallel with other than NI Devices via ExpressCard everything is working fine.
Even the NI Stuff in Parallel with others than the GPIB Adapter connected Device works fine.

The Reason i tell it here in your forum is because i got to the conclusion that it only can be the Driver for the KUSB-488B.
I know that it can be a lot of all else usb-stuff connected, but disabling, removal, ... let me came to this assumption.
I even tried to connect via an old usb 2.0 Hub - but no changes using the generic usb hub.

After Hours of Investigation and Try-Outs where everything works fine (with other USB-connected Devices!) i can't
figure it out.
I read about your topic viewtopic.php?f=13&t=138576 concerning a beta-version of Windows 10 Driver
and recognized that there even is no official Support for Windows 10 or yet a download available for that beta-version.

I really don't know how to go on. Does anyone know if there's a Problem with it since Microsoft changed the USB Stack with the involvement of Windows 8.1?
I am only able to test on Windows 10 ... and we need it! I can't switch back to windows 7 for several reasons.
Is there a hotfix from Microsoft available concerning this issue? Do you have a newer driver version for me .. even beta?
Does there exist a work-around or known windows 10/8 issue with the driver?

A lot of posts for this BSOD exists on the internet. But all come down to kick-out the faulty drivers.
Common errors there are due to old drivers using the usb 3.0 extensible interface (usbxhci.sys)
My Chipset Drivers are up-to-date. Everything works fine, but not in parallel usage of the NI ExpressCard Controller interface.
Maybe someone discovered similar behaviour with the ni-pxi-stuff?

The last one chance that actually seems to may work for me is to use another gpib adapter. But i thought to have a good one!
The driver for the national instruments adapter provides actual drivers and are whql certified.
But I don't want to switch from SCPI to the NI Commands and have to change my adapter. In general i'd always prefer
non-NI solutions for several personal concerns.

Please give me any suggestions or hints where to search on. Everything seems to work well but not in parallel with the NI-Stuff.
I think there is a severe windows 10 driver problem.

Do you see any chances to fix it by using your announced beta-version of the driver?
if so, where can i get it?

Thanks to any answers ...

Stuart M
Keithley
Keithley
Posts: 444
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Model 2002 / KUSB-488B Driver Issue

Post by Stuart M » November 22nd, 2016, 7:21 am

Are you using Windows 10 Pro 64-bit or 32-bit?
(Also I will send you a private message to get your contact info, send me a response if you would like a beta copy of the new driver)

CalibratorFloppy
Posts: 2
Joined: November 22nd, 2016, 4:31 am
Country: Germany

Re: Model 2002 / KUSB-488B Driver Issue

Post by CalibratorFloppy » November 22nd, 2016, 7:33 am

Sorry ... forgot to mention ... it's 64 bit

Vince W
Keithley Applications
Keithley Applications
Posts: 108
Joined: September 22nd, 2010, 12:27 pm
Country: United States

Re: Model 2002 / KUSB-488B Driver Issue

Post by Vince W » November 23rd, 2016, 10:59 am

You are correct in that we have not released a driver for the KUSB-488B USB/GPIB interface that supports Windows 10. If it helps at all, we are wanting this too. Stuart M is the right person to contact.

In the meantime, are you installing the KUSB-488B driver as "Keithley Command Compatible" or "NI Command Compatible"?
For what it is worth, my own experience has proven that "NI Command Compatible" works better with other NI drivers.
Image
A Greater Measure of Confidence

zvikaef
Posts: 14
Joined: June 9th, 2016, 2:57 am
Country: Israel

Re: Model 2002 / KUSB-488B Driver Issue

Post by zvikaef » February 12th, 2017, 5:01 am

Hi Stuart.
I'll appreciate if you will send me a link for the beta version KUSB-488B driver for win 10.
I need it for a customer.
Thx
zvika

Stuart M
Keithley
Keithley
Posts: 444
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Model 2002 / KUSB-488B Driver Issue

Post by Stuart M » February 12th, 2017, 2:50 pm

Zvika,
I will send you a private message that you can reply to...to get the driver.
Best regards,
--Stuart

zvikae
Posts: 20
Joined: July 12th, 2016, 12:55 am
Country: Israel

Re: Model 2002 / KUSB-488B Driver Issue

Post by zvikae » February 12th, 2017, 10:18 pm

hi stuart.
could not find the private message, please resend

Stuart M
Keithley
Keithley
Posts: 444
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: Model 2002 / KUSB-488B Driver Issue

Post by Stuart M » February 13th, 2017, 6:52 am

I have sent a private message to both of your listed accounts (zvikae & zvikaef).
Please login and check again.
Regards,
--Stuart

Post Reply

Return to “Series 2000 and Series 2100 DMM's”

Who is online

Users browsing this forum: No registered users and 1 guest