Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

2260B-80-13 LabVIEW Error

2260B-30-36, 2260B-30-72, 2260B-80-13, 2260B-80-27
Post Reply
Robert S
Posts: 2
Joined: April 3rd, 2017, 3:29 am
Country: Austria

2260B-80-13 LabVIEW Error

Post by Robert S » April 3rd, 2017, 3:47 am

Hello!
I hope the desciption on my problem makes any sense to you guys.

I have a 2260B Power Supply and - in the Long run - want do use it as a power source and a measurement device simultaneously using LabVIEW via a USB-Connection (no GPIB).
After installing the USB-Driver and changing the device setting (F-22 to 2) I wanted to check the LabVIEW-examples provided by keithley.
So after starting "Keithley 2260B Output DC Voltage and Current", choosing the VISA resource "COM4" and setting the Voltage (11,0V) and Current (0,01A) I was confident this would lighten up my LED.
But as I press the run button I get an error message:

Error -1074000000 occurred at Keithley 2260B.lvlib:KE2260B Error Query.vi
Possible reason(s):

Instrument reports:
-115,"Unexpected number of parameters"
+0,"No error"



Complete call chain:
Keithley 2260B.lvlib:KE2260B Error Query.vi
Keithley 2260B.lvlib:KE2260B Configure OVP.vi
Keithley 2260B Output DC Voltage and Current.vi

I am relatively new to programing and was hoping someone with more experience could "translate" this for me or could tell me where I might have made a mistake!?
Maybe someone had the same problem in the past or would even try to do the same Task as I am planning to do?

Thiagoc
Posts: 1
Joined: September 5th, 2017, 6:20 pm
Country: Brazil

Re: 2260B-80-13 LabVIEW Error

Post by Thiagoc » September 5th, 2017, 6:22 pm

Did you find a solution? I have the same problem.

Robert S
Posts: 2
Joined: April 3rd, 2017, 3:29 am
Country: Austria

Re: 2260B-80-13 LabVIEW Error

Post by Robert S » January 23rd, 2018, 2:14 am

Hello, sorry for the late Response, but my work focus shifted a little and honestly I forgot about this post up until now.

Unfortunately I did not come up with a solution to the problem. Any chance you did in the meantime?

Kind regards!

Dave W
Tektronix Applications
Tektronix Applications
Posts: 266
Joined: April 26th, 2010, 12:01 pm
Country: United States

Re: 2260B-80-13 LabVIEW Error

Post by Dave W » February 7th, 2018, 11:37 am

Robert S wrote:
April 3rd, 2017, 3:47 am
So after starting "Keithley 2260B Output DC Voltage and Current", choosing the VISA resource "COM4" and setting the Voltage (11,0V) and Current (0,01A) I was confident this would lighten up my LED.
I notice you wrote your voltage and current values using commas ',' instead of periods '.' for the decimal point. Is this what is being sent to the instrument? The instrument will not interpret ',' as the decimal point and interprets this as a parameter separator. You may need to adjust your localization setting so the driver converts the floating point value to a string with the proper format.

Post Reply

Return to “Series 2260 Programmable DC Power Supplies”

Who is online

Users browsing this forum: No registered users and 1 guest