Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Problem reading the buffer on 2182A

2182 Series Support
Post Reply
mobius727
Posts: 2
Joined: June 3rd, 2015, 10:59 pm
Country: India

Problem reading the buffer on 2182A

Post by mobius727 » June 9th, 2015, 2:31 am

Hi,

I'm trying to store a particular number of readings in the buffer and read them all at once. I've attached the program I've written to do this. I used the :TRAC:DATA? command to do this, but it doesn't appear to work.

The front panel of the instrument gets updated accordingly, but the program times out and does not give out any readings. It gives me an error saying Error -1073807339, timeout expired.

When I remove the TRAC:FEED:CONT NEXT command, there are no errors given out but it reads an empty buffer, that is, it returns all zeroes.

Why isnt this program working? Thanks in advance.
Attachments
2182A1.vi
(13.86 KiB) Downloaded 1466 times

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Problem reading the buffer on 2182A

Post by Dale C » June 9th, 2015, 7:29 am

1. The SAMPLE:COUNT should match the TRACE:POINTS. So use 10 for each.
2. Insert a short delay between*TRG and TRACE:DATA?.
3. TRACE:FEED:CONT NEXT is required to place data into the buffer.
That should do it.

mobius727
Posts: 2
Joined: June 3rd, 2015, 10:59 pm
Country: India

Re: Problem reading the buffer on 2182A

Post by mobius727 » June 9th, 2015, 9:41 pm

Thank You, adding the delay fixed my problem!

Post Reply

Return to “Nanovoltmeters”

Who is online

Users browsing this forum: No registered users and 3 guests