Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Model 2182A trouble using digital filter (repeating)

2182 Series Support
Post Reply
z.diam
Posts: 1
Joined: March 27th, 2018, 1:46 am
Country: United Kingdom

Model 2182A trouble using digital filter (repeating)

Post by z.diam » March 27th, 2018, 2:02 am

I am trying to integrate a signal over a fixed time and then clear the buffer ready for the next measurement on a Keithley 2182A. I have fixed the rate (NPLC) and digital filter count to 9 and 12 respectively, which I think should give me 180ms x 12 (2160ms total). I have set the digital filter to repeating so that it will give me an average of the 12 readings and then discard the stack ready for the next measurement. It does wait for 2160ms and then give an answer, however, I don't get a sensible answer (it is 2 orders of magnitude out).

When I use the moving average filter I get a sensible result, but, it does not give me an average across the time that I want - the reading is given almost instantaneously as the trigger is sent. I need to average across the whole time period, not just the first hundred milliseconds or so.

How can I get the repeating filter to work this way? And why is the moving average giving me a reading instantaneously?

Post Reply

Return to “Nanovoltmeters”

Who is online

Users browsing this forum: No registered users and 3 guests