Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

2182A Channel 2 microVoltage Measuring

2182 Series Support
Post Reply
gelmand
Posts: 26
Joined: May 16th, 2012, 12:06 pm
Country: Canada

2182A Channel 2 microVoltage Measuring

Post by gelmand » May 31st, 2012, 1:09 pm

Hello,

First off I would like to say thanks for the people that were helping me out earlier, means a lot that I have some guidance, I have definitely learned a lot. I am off to another portion of my project. I need to perform voltage measureing at a 10 uV region using the 2182A's 2nd Channel. I made a little program (attached).

The program works wonders with a 1.5V AA battery as a test, but only in HIGHLIGHT EXECUTION mode. When I turn off highlight execution mode and run the same test, the last index of the previous buffer just gets repeated throughout the current buffer making all the current buffer readings the same. The buffer never gets reset and doesn't acquire new readings (when not in highlight execution).

Also when I try to detect a 10uV source using my 2400, it cant - it up and I get random readings. How can I record small values with Ch2? The measurement capabilities state 10nV to 12V (Ch2), so there must be a way.

Thank you,
Danny
Attachments
Dilatometer.vi
(25.68 KiB) Downloaded 1243 times

Dale C
Keithley Applications
Keithley Applications
Posts: 2847
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: 2182A Channel 2 microVoltage Measuring

Post by Dale C » June 1st, 2012, 7:04 am

Can you resave and repost the VI for Labview 2010?
Also the Model 2400 voltage measurement accuracy is only good to about 300uV.
You might be able to see 10uV level shifts, but it would not be accurate to 10uV level.

gelmand
Posts: 26
Joined: May 16th, 2012, 12:06 pm
Country: Canada

Re: 2182A Channel 2 microVoltage Measuring

Post by gelmand » June 1st, 2012, 8:33 am

Hey Dale!

I am not measuring with the 2400, I am only sourcing it at 10uV so I can test CH2 of my 2182A. Attached is the 2010 version (I hope I converted it correctly) with my VI and the keithely drivers.

Thank you so much,
Danny
Attachments
Dilatometer2010.zip
(112.13 KiB) Downloaded 1220 times

gelmand
Posts: 26
Joined: May 16th, 2012, 12:06 pm
Country: Canada

Re: 2182A Channel 2 microVoltage Measuring

Post by gelmand » June 1st, 2012, 11:12 am

Hello Dale,

I ran the program I made source 0.5V with the 2400. The results are on the left side of the attached image.

I think there is something wrong with the Keithley 2182 Buffer Read.vi. I went into the subVI and ran JUST the read buffer VI, and it spat out the correct values in the new buffer, showed on the right side of the attached image. There must be something wrong with my program since it is not updating the new buffer values. Is there a precursor I am missing?

Also I am posting the front/block panel of my vi, just in case my conversion didn't work.

Thanks,
Danny
Attachments
vi.jpg
Sequence 1 and 3 from the block panel are just initiating and aborting the source voltage from 2400, respectively
vi.jpg (605.36 KiB) Viewed 15408 times
error.jpg
error.jpg (651.54 KiB) Viewed 15409 times

Post Reply

Return to “Nanovoltmeters”

Who is online

Users browsing this forum: No registered users and 1 guest