Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

6485 Return to Idle from Trigger

2502, 6485, 6487 - Support
Post Reply
ESatkiewicz
Posts: 1
Joined: August 8th, 2014, 8:32 am
Country: United States

6485 Return to Idle from Trigger

Post by ESatkiewicz » August 8th, 2014, 8:52 am

Hi,

I am writing a program to control a 6485. The program has two user modes:
1) Continuously measure current at regular intervals and update rolling graph.
2) Trigger mode - Record a measurement after each TLINK trigger.

The program begins in continuous mode. If the user starts trigger mode, everything works as expected. However, when the user attempts to abort the trigger mode and return to continuous mode, the 6485 locks up UNTIL one more trigger is sent. Once that final trigger is sent, I get an error: +800 - Illegal with storage active, then all queued commands go through and continuous mode works fine. I have tried numerous sequences of commands to get the 6485 back to an idle state to receive my commands, but nothing is working. Any ideas?

Thanks,

Paul

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: 6485 Return to Idle from Trigger

Post by Dale C » August 13th, 2014, 12:41 pm

Hi Paul,
Abort should take the instrument back to idle state.
:ABORT

Razaali1
Posts: 1
Joined: September 20th, 2014, 3:34 am
Country: Austria

Re: 6485 Return to Idle from Trigger

Post by Razaali1 » September 20th, 2014, 3:50 am

Hello,

My apparatus is as follows: Keithley 6482, Pulse Generator, Power Supply of the Electron Gun, Electron gun itself, Sample connected to the channel of 6482.

My questions:
1) Can 6482 be used as an external trigger to activate pulse generator which will the send a signal to the Power Supply of the Electron Gun and store the measured current on the buffer of 6482?
2) If this is possible, can you give me directions on how to set up the trigger and buffer to record measurements.

Best Regards

Post Reply

Return to “PicoAmmeters”

Who is online

Users browsing this forum: No registered users and 3 guests