Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Triggering of 6482 using KI-488 Diagnostic Tool

2502, 6485, 6487 - Support
Post Reply
milosbasovic
Posts: 16
Joined: June 23rd, 2014, 6:19 am
Country: United States

Triggering of 6482 using KI-488 Diagnostic Tool

Post by milosbasovic » June 4th, 2015, 10:02 am

Dear Sir or Madame,

I am trying to trigger 6482 by using KI-488 and *TRG command, but I keep getting ERROR: ID CODE -211 trigger ignored

I have already used front panel commands to set up the trigger if following manner:
Arm-Layer:
ARM-IN: GPIB
ARM-OUT: Line: #1
ARM-OUT: Events: TRIG-LAYER-DONE=OFF
COUNT: FINITE: 1

Trig-Layer:
TRIGGER-IN: TRIGGER-LINK
TRIGGER-OUT: Line: #1
TRIGGER-OUT: EVENTS: SOURCE=OFF DELAY=ON MEAS=ON
DELAY: 1s
COUNT: 3

What I am trying to do is, instead of pushing TRIG button on the front panel, send a command that will do that.
Am I using the wrong command or is there something else?

Best Regards,

Milos

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by Dale C » June 4th, 2015, 11:05 am

Milos,
You have everything correct except two things.
Start the program with *RST.
This place the 6482 in the IDLE state.
then send an :INIT
Now when you are ready, send the *TRG to trigger.
That should do it.

milosbasovic
Posts: 16
Joined: June 23rd, 2014, 6:19 am
Country: United States

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by milosbasovic » June 4th, 2015, 11:51 am

Hello Dale,

All parameters of the trigger are preset manually on the front panel of the device. When I use *RST it resets the whole 6482 to the factory settings. I need the trigger settings to stay the same after each *TRG command since I am varying parameters on an electron gun as well in a separate program. Basically, my Trig-Layer count is 3 for a single energy of an electron gun, and I am recording 20 different energies. To save the data in the 6482 memory buffer I have set the STORE to 60 memory spaces. I need a way to trigger the 6482 that will stop after each Trig-Layer until I change the electron gun energy value and continue once I give it a next *TRG command.

I need to remotely send a trigger command that will do the same thing as pressing TRIG button on the front panel of the 6482?
When I send just *TRG it gives me -211 error code (trigger ignored).

Milos

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by Dale C » June 4th, 2015, 11:58 am

Ok, you do not have to use *RST. I just thought it would start with a "known" default on all parameters.
You could start with
:ABORT
That will place the unit in IDLE.
When you are done with all the other parameter configurations, then send
:INIT
to get the unit out of IDLE and into the trigger model and waiting for the *TRG.
then
*TRG
to take the measurements.

milosbasovic
Posts: 16
Joined: June 23rd, 2014, 6:19 am
Country: United States

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by milosbasovic » June 4th, 2015, 12:40 pm

For some reason it still gives the same error -211.

I have tried:
:ABORT, it deactivates the ARM word on the screen (it's IDLE)
:INIT, it activates the ARM word on the screen (out of IDLE)
*TRG, gives me "-211 trigger ignored" message, when I press "Send" command on KI-488

Do you have an idea why the error might be appearing? Maybe it has something to do with trigger parameters that I set up

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by Dale C » June 5th, 2015, 7:32 am

What is the direction on the ARM Layer?
It should be set to ACCEPTOR.
:ARM:DIR ACC
If it is set to SOUR then it will bypass the ARM layer the first time. So when you send the *TRG it is already triggered.
See if this helps.

milosbasovic
Posts: 16
Joined: June 23rd, 2014, 6:19 am
Country: United States

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by milosbasovic » June 8th, 2015, 1:27 pm

I have tried both settings and none of them allowed me to send the trigger command.
It still reads the same error.

milosbasovic
Posts: 16
Joined: June 23rd, 2014, 6:19 am
Country: United States

Re: Triggering of 6482 using KI-488 Diagnostic Tool

Post by milosbasovic » June 10th, 2015, 8:40 am

Hi Dale,

I figured it out.
I have to send :INIT and then *TRG to remotely trigger the device.
Thanks for your help.

Best Regards,

Milos

Post Reply

Return to “PicoAmmeters”

Who is online

Users browsing this forum: No registered users and 2 guests