Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

SCPI & 6621

6220, 6221 Current Sources
Post Reply
angelo
Posts: 8
Joined: September 11th, 2015, 6:35 am
Country: Brazil

SCPI & 6621

Post by angelo » January 9th, 2017, 11:53 am

Guys, can someone tell me what is wrong for this situation below ?

if I send "SOUR:WAVE:FUNC SIN" it is ok
if I send "SOUR:WAVE:FREQ 227" it is ok

but if I send "SOUR:WAVE:FUNC SIN;SOUR:WAVE:FREQ 227" I got an error -113

angelo
Posts: 8
Joined: September 11th, 2015, 6:35 am
Country: Brazil

Re: SCPI & 6621

Post by angelo » January 9th, 2017, 12:14 pm

The same I have for:

"SOUR:WAVE:DUR:TIME INF;SOUR:WAVE:RANG BEST" I got error -113

"SOUR:WAVE:DUR:TIME INF" is OK
"SOUR:WAVE:RANG BEST" is OK

Kenneth P
Keithley Applications
Keithley Applications
Posts: 212
Joined: October 25th, 2010, 1:31 pm
Country: United States
Contact:

Re: SCPI & 6621

Post by Kenneth P » January 12th, 2017, 10:02 am

I'm not sure what the issue may be. I checked the LabVIEW driver for the 6221 and found numerous line sends where multiple commands are concatenated using a semi-colon.
If you happen to be using the National instruments VISA DLL in your code, I suggest that you use NI I/O Trace to determine if all the code is being sent.

Tad Bak
Posts: 3
Joined: January 24th, 2017, 8:18 pm
Country: Australia

Re: SCPI & 6621

Post by Tad Bak » January 25th, 2017, 3:54 am

I had a similar problem with different instructions. In my case I have solved it by adding a colon after semicolon. Please try:

"SOUR:WAVE:FUNC SIN;:SOUR:WAVE:FREQ 227"

Hope this helps.

Post Reply

Return to “Current Sources”

Who is online

Users browsing this forum: No registered users and 2 guests