Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Visa read error from Keithley 6221 using TCPIP

6220, 6221 Current Sources
Post Reply
sgss1b05
Posts: 1
Joined: July 11th, 2018, 11:08 am
Country: Ireland

Visa read error from Keithley 6221 using TCPIP

Post by sgss1b05 » July 11th, 2018, 11:19 am

Hello all,

There is an error which bothers me for long :cry: . It will be very kind of you if anyone can advise about it.

I tried to run a delta-pulse measurement using Keithley 6221 with Keithley 2182A through TCP/IP. I find very often errors are generated by the VISA_Read in the error query vi. Sometimes I get green Error 1073676293 (The specified termination character was read) and sometimes it shows red Error 85 (occurred at Scan From String (arg 1)). See - error1.

To examine the effect of VISA_Read, I made a simple test program consisted of reset and read function. And I get another error -1073807339 (Timeout expired before operation completed). See - error4.

I was very confused with the read vi. So I decide to use test panel of Ni_Max. I write the query command ?IDN?\n in the test panel. I find enabling "Suppress End on Read" option will cause read operation timeout error (see - test3.1). This problem can be solved after I disable it or enable the "Termination character" with line feed \n (see - test1.1).

I am not sure either if it is a problem of Keithley device or my code or the communication set-up. I have checked the device can receive the signal for DC mode which does not involve reading of buffer. The device cannot be detected automatically by Ni_Max so I added manually using TCPIP socket with 1394 port. The GPIB cable will block the RS232 port which is needed for 6221 to communicate with 2182A, so I did not use it.

I spend many hours try to resolve it :oops: . It will be really helpful if someone can provide tips or hints to solve it.

Many thanks,
Thomas
Attachments
test3.1.PNG
test3.1.PNG (75.85 KiB) Viewed 4084 times
error4.png
error4.png (27.69 KiB) Viewed 4084 times
error1.png
error1.png (125.53 KiB) Viewed 4084 times

Adelaide Bradicich
Posts: 1
Joined: August 21st, 2018, 9:04 am
Country: United States

Re: Visa read error from Keithley 6221 using TCPIP

Post by Adelaide Bradicich » August 21st, 2018, 9:06 am

Hey! Did you figure this out? I'm having the same problem using an ethernet cable for connection.

Andrea C
Keithley Applications
Keithley Applications
Posts: 1279
Joined: October 15th, 2010, 10:35 am
Country: United States
Contact:

Re: Visa read error from Keithley 6221 using TCPIP

Post by Andrea C » August 23rd, 2018, 6:25 am

In the test.vi block diagram, you are attempting to do a VISA Read without any prior writing of a command that would cause a response.
You need to write some sort of querying command, something that ends with question mark, and only then will the instrument "have something to say" and can give you some info when you do VISA Read. Otherwise, a VISA Timeout will result for the attempt to Read.
For example, send *idn? before the Read.

The 6221 will want to see the line feed terminator. For every command that you VISA write, you can append the \n onto it, or at the VISA session level you can specify the terminator and enable appending it. Do one or the other, but not both.

Post Reply

Return to “Current Sources”

Who is online

Users browsing this forum: No registered users and 2 guests