Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

7705 Relays Not Toggling

7001, 7002 and Switch Cards
Post Reply
anthonyk
Posts: 3
Joined: January 17th, 2015, 11:44 am
Country: United States

7705 Relays Not Toggling

Post by anthonyk » January 19th, 2015, 6:55 am

I am using two 7702 modules and two 7705 modules in a 2750 Multimeter/Switch System. Everything was working well and I was controlling the system over RS-232 with the VB.net DLL. After a while, one of the 7705 modules stopped opening and closing its relays, both when controlled via RS-232 and when using the front panel CLOSE MULTI command. I tried swapping the two 7705 modules and the problem followed the module.

Why would the 7705 module stop responding to commands and how can I restore operation?

Thank you

Joseph V
Keithley Applications
Keithley Applications
Posts: 107
Joined: July 1st, 2014, 10:31 am
Country: United States

Re: 7705 Relays Not Toggling

Post by Joseph V » January 19th, 2015, 8:22 am

Hello,

Can you send your 2750 the following command.

:ROUTE:CLOSE:COUNT? (@X01 : X40) Where X is the slot number of your faulty 7705.

It may be possible that the relay has reached the end of its life cycle in which you would need to get it repaired.
Please report back to me which relay is the nonworking one and what the closure count is for it.

-Joe

anthonyk
Posts: 3
Joined: January 17th, 2015, 11:44 am
Country: United States

Re: 7705 Relays Not Toggling

Post by anthonyk » January 19th, 2015, 8:47 am

I just received this module so it is pretty much unused.

46,34,32,29,30,28,26,27,26,26,27,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

All switches should be open but I measure closure on many of the switches that were previously working. They seem to be stuck in some previous state.

Joseph V
Keithley Applications
Keithley Applications
Posts: 107
Joined: July 1st, 2014, 10:31 am
Country: United States

Re: 7705 Relays Not Toggling

Post by Joseph V » January 19th, 2015, 11:28 am

What sort of signal levels were you switching/monitoring? What type of DUTs are you connected to?

It may be possible that an inrush current may have damaged the legs of the relays, essentially the contact points act like Velcro.

anthonyk
Posts: 3
Joined: January 17th, 2015, 11:44 am
Country: United States

Re: 7705 Relays Not Toggling

Post by anthonyk » January 19th, 2015, 11:38 am

I did not have any DUTs connected because the fixtures are not yet complete. The output pins are only connected to another header through a cable harness. I was just working on the control software when this happened.

Post Reply

Return to “7000 Series Switch”

Who is online

Users browsing this forum: No registered users and 2 guests