Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Keithley S46 Occasional Loss of 3dB

Post Reply
Dpalmer
Posts: 1
Joined: June 10th, 2015, 2:49 pm
Country: United States

Keithley S46 Occasional Loss of 3dB

Post by Dpalmer » June 10th, 2015, 3:16 pm

I have an S46. I have chained the last three switches effectively creating a x16 switch. Occasionally one of the switches in the chain is causing a 2.5dB drop that is steady (meaning it doesn't improve or degrade during the test).

Tx Verify Power 10.23365031 7.68822384 10.01098885 7.755706806 10.19233719 10.16008226 10.15011668 10.10973245 7.69768496 10.21434703

As you can see from the above, it's nearly a perfect 2.5dB. My device output is 10dB yet I see 7.5 or 7.6 occasionally. Between each of the above readings, I have rotated the switch off of the position and then back on. If I perform the same test without rotating the switch, it never changes values. Do I have a bad switch? I have barely used this one.

Dale C
Keithley Applications
Keithley Applications
Posts: 2849
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Keithley S46 Occasional Loss of 3dB

Post by Dale C » June 12th, 2015, 5:56 am

It could be one of two things.
1. Intermittent relay.
2. Intermittent cable connection.

Do you have any other SP4T or SP6T relays in the S46 that you could test?
Or do you have just the three relays you mention?
Cabling is critical at these frequencies. Check to be sure the SMA cables are securely fastened.
Do you have the load terminated? usually 50 ohms is a good terminator. If not, you may be seeing some reflections.

Post Reply

Return to “Other Switches”

Who is online

Users browsing this forum: No registered users and 1 guest