Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

TDS3014B startup issues

DPO/MSO/MDO4000 Series, DPO/MSO/MDO/TDS/THS3000 Series, DPO/MSO/TDS/TPS2000 Series, TBS/TBA1000 Series
Post Reply
michael.allard
Posts: 2
Joined: November 18th, 2016, 2:05 am
Country: United Kingdom

TDS3014B startup issues

Post by michael.allard » November 18th, 2016, 2:23 am

Hi Forum,

I wonder if anyone else has had any experience with the issue i am having. I have a TDS3014B scope that fails to start initially, but repeated attempts will eventually allow the scope to get past the problem, and then function correctly, and pass the diagnostics testing in repeated loop (200+ cycles). It is powering up beyond the splash screen to the point where the front panel lights flicker, and relays click, and this is where it stops. sometimes displaying a screen with the graticule window, or just the screen without graticule.

The error log is reporting CPU and Display Failures.

I have verified all voltages correct on the front panel probe connector, and have tried running DC into the battery connector which also exibits the same behaviour. I have also noticed that the clock time is incorrect, and when resetting it, this is not stored, suggesting that the battery in the Dallas RTC/RAM has run out. Could this be the problem? I also plan on replacing the electrolytic capacitors on the DC rails, as the scope has not been used in a long while. I dont really want to be spending a large amount on this given its age. I was given the scope which at the time needed the front panel rotary switches cleaning, and it was working ok.

Any help or advice would be appreciated.

Thank you.

Mike.

johnn635
Posts: 1
Joined: May 19th, 2017, 2:49 am
Country: United Kingdom

Re: TDS3014B startup issues

Post by johnn635 » May 19th, 2017, 4:05 am

Hi Mike and other forum users and the Tek board admin,
I also have a TDS3014B wiuth similar symptoms.
The timeline was this.

The unit was being used and then the front panel controls became unresponsive. Power cycling would sometimes restore operation for a short period, but not consistently.

Having enquired from Tek the cost of repair ( more than you can get a comparably specified scope for - but without some of the TDS3014B fancy features - the unit was put in a cupboard for several months. When it was powered up again it initially worked, but only for a few minutes. When a display was obtained, time and date were correct, even several years later.

The unit was then left for several further years and is now in front of me with a scope ( not Tek!). The calibrator output is absent. and the only sign of life is the logo screen, and a brief flash of the panel LED's and relays clicking. Even this is intermittent.There is 5V and 15V on the probe connectors. The erthernet port, which by default is dhcp, has no connectione either, although the network switch sees a connection. I believed the rear 'CAL' switch accessed through the small hole, had some effect, but not now.

The only other noticeable activity is a brief flickering of the screen 4 or five times as though there is an attempt to display a message.

I am at least 50% sure the problem is a capacitor problem, since all the internal voltages probably depend on good caps, and a bad one is hard to find - especially without a schematic - hint hint Tek. The main PSU is OK, as proven by the fact that operating from an external DC makes no difference.

A couple of questions Mike - how did you get the error log - or was this when you could get it to work past the initial logo screen? By repeated attempts - do you mean power cycling or some other way of 'rebooting it'; I am using the hard to find documented BTrig/MENU key whilst powering up, but is there another one which forces a full reset?

Finally, 6 months later, did you replace any caps and have you succeeded in resurrecting the scope?

John

PS I just put a floppy in the drive and did a couple of power cycles and I suddenly saw that the 5V 1kHz is now present! However, I had also been using the BTrig/MENU reset. Now it seems to be OK, but intermittent, and has now gone again. It corresponds to the flashing of the front panel LEDs and the relay clicking. If these are absent, then there is no calibrator. At the moment it gives an output every time. How frustrating.

michael.allard
Posts: 2
Joined: November 18th, 2016, 2:05 am
Country: United Kingdom

Re: TDS3014B startup issues

Post by michael.allard » November 30th, 2018, 3:58 am

Hi johnn635

Thanks for your reply, Sorry I never noticed it earlier. Yes the log was only accessed after a successful boot. I have since repaired the scope, and the solution was actually quite simple in the end. I had noticed that when it did boot, the time and date was incorrect, caused by the Dallas RTC module, mentioned a lot in these forums. replacing this cured the startup problems, so I can only assume that there were some startup settings stored in the RAM that were causing the issues.

Though it sounds like your RTC was keeping time, you have tried the DC powering method too. I did not need to change any of the capacitors in the end either.

I was unaware of the BTrig/MENU so thank you. I've also since this problem obtained the last released Firmware and updated this, though the intermittent nature you see sounds more like a hardware fault, though if you can boot into the firmware update mode, it may be worth a shot.

thanks,

Mike

Post Reply

Return to “Non- Windows Based Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 2 guests