Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

MDO4054C: SPI bus event table?

DPO/MSO/MDO4000 Series, DPO/MSO/MDO/TDS/THS3000 Series, DPO/MSO/TDS/TPS2000 Series, TBS/TBA1000 Series
Post Reply
vadim.b
Posts: 3
Joined: May 13th, 2020, 7:45 am
Country: Belgium

MDO4054C: SPI bus event table?

Post by vadim.b » May 13th, 2020, 9:11 am

Hello,

I am debugging the transfers over SPI bus. The settings are:
  • Framing: SS
  • Trigger on: SS Active


The MCU exchanges 5 frames with the device (SS is active 5 times):

tek-5-spi-frames.png
tek-5-spi-frames.png (19.01 KiB) Viewed 152 times


The first two frames, zoomed in, look like this:

tek-two-first-frames.png
tek-two-first-frames.png (18.6 KiB) Viewed 152 times


But the event table shows only one event, which is all the data transferred in all 5 frames:

tek-spi-event-table.png
tek-spi-event-table.png (14.78 KiB) Viewed 152 times



Is it possible to see 5 events in the event table?

Am I missing something? I have read the relevant sections of the User Manual and have searched this forum. Couldn't find the answer.

The scope is MDO4054C, firmware v1.08.

Kind regards,
Vadim

vadim.b
Posts: 3
Joined: May 13th, 2020, 7:45 am
Country: Belgium

Re: MDO4054C: SPI bus event table?

Post by vadim.b » June 8th, 2020, 4:55 am

ping tek.com

w2aew
Tektronix Applications
Tektronix Applications
Posts: 137
Joined: December 2nd, 2008, 2:27 pm
Country: United States
Contact:

Re: MDO4054C: SPI bus event table?

Post by w2aew » June 8th, 2020, 7:41 am

Double check your bus setup and the threshold settings for the SS line. You can see the start of frame which is the green [ symbol, but the end of frame should show up as a red ] symbol. This is not shown with makes me think that maybe the threshold isn't set correctly.
tek00000.png
tek00000.png (32.27 KiB) Viewed 93 times
tek00001.png
tek00001.png (36.61 KiB) Viewed 93 times

vadim.b
Posts: 3
Joined: May 13th, 2020, 7:45 am
Country: Belgium

Re: MDO4054C: SPI bus event table?

Post by vadim.b » June 9th, 2020, 7:23 am

w2aew wrote:
June 8th, 2020, 7:41 am
Double check your bus setup and the threshold settings for the SS line.
Yep, that was it! Thank you for the hint.

SS threshold was on par with that of MOSI and MISO, but way too high for frame end detection.

Kind regards,
Vadim B

Post Reply

Return to “Non- Windows Based Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 4 guests