Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Tektronix TDS5054 oscilloscope repair - PC interface board hangs

Questions in this forum area are community supported. Tektronix does not regularly monitor posts in this area.
Post Reply
MiMatt
Posts: 5
Joined: October 19th, 2017, 9:22 am
Country: United Kingdom

Tektronix TDS5054 oscilloscope repair - PC interface board hangs

Post by MiMatt » October 26th, 2021, 2:12 pm

Good Day,

I am trying to resurrect a TDS 5054 (non-B) oscilloscope, which suffers from an error in terms that the Tek scope application fails to start.
Serial number is B04xxxx. The PC system itself and Windows 2000 OS are operating just fine. The CMOS battery on the Intel D815EFV PC motherboard needed to be replaced.

However, the Tek scope program produces the "System error..." message as reported by other users.

I am aware that this is a very looong post, but I am running out of ideas and wanted to provide as much information as needed for anyone who wants to help.

The irritating bit is that both LEDs CR700 and CR710 on the PC interface board remain turned on. LED CR710 "PAI LOAD ERROR" goes low briefly on power-up.

The debug port remains static, i.e. TXD and RXD are static around -10V; same for the static logic inputs on the MAX323 interface TxR at connector J1050.

This stays the same with TDS 5000 "Firmware" release V1.2.1 as well as with V1.1.5 installation. I conclude from the release notes that this device shall operate fine with release V1.2.1, as it has a Celeron 1.2 GHz CPU.
  • The PC Interface sticker reads "664-5123-02", and it has an orange barcode sticker that reads "03WYDT".
  • The Acquisition board sticker reads "664-5278-04" and has an orange barcode sticker that reads "0405XH". Next to this is a board label in the top level copper mask "389315801C".
I had also posted this on the eev blog forum, https://www.eevblog.com/forum/testgear/ ... ard-hangs/. For convenience, I am including most of the details from that posting below.

The PC's Windows device manager shows two related devices; a Tektronix I/O processor (PCI slot 1, PCI bus 2, Device 3, function 0) and a NI PCI GPIB card (PCI slot 1, PCI bus 2, Device 15, function 0) . No conflicting PC resources are shown and i.e. IRQ #9 is used by both.

There is a windriver tool located in the C:/tektronix/custom folder, which can serve as some sort of PC diagnostics tool. This detects the following resources:
PCI: Intel S21152BB PCI to PCI bridge
PCI: C&T 69000 AGP/PCI Flat panel/CRT VGA accelerator
PCI: IBM 405GP PLB to PCI bridge (this is the PowerPC controller)
PCI: Nat. Inst. PCI-GPIB GPIB Controller interface board.

I may want to add that the error remains the same with the original HDD and when testing another motherboard (I have tested a 2nd Intel 815EFV motherboard for this).

I would certainly appreciate any pointers or tests I can run. I am operating the complete hardware outside the housing on my bench, so I can probe testpoints etc.

My basic questions are:

Q1: On the PowerPC board: As LED CR710 "PAI LOAD ERROR" on the PC interface board remains on, there is a problem with this board. However, the serial "debug port" outout from the MAX232 at connector J1050 shows no sign of any booting of VxWorks or any activity. How can I stimulate or test the PowerPC controller? Also, the DS75 thermometer on the PC interface board shows some I2C bus activity, so the PowerPC as the I2C bus master is not completely dead...
Q2: On the acquisition board: I have verified that all power supplies on the board and that the 5V supply and main oscillator for the ATMEL AT90LS8535 controller are working properly. This controller shows some activity on its PD2 to PD7 bus interface, but its other interfaces PC, PD, PA, PB and the SPI bus are static, same for the UART. Is there any way to test the function of the acquisition board,i.e. by manipulating test points or the mentioned Atmel controller?

Please help me with getting this instrument back to operate. It surely is a nice piece of T&M equipment that I could put to good use in my home labs.

Thanks for reading through all of this!


Cheers,

Matt.

From the above posting on the eev blog forum:

Hardware troubleshooting:

  • I have cloned the HDD and replaced it with a 120 GByte mSATA solid state disk and a Delock type 62495 adapter (mSata to 44pin IDE)
  • The primary symptom is that the start-up sequence of the PC interface board alias PowerPPC board fails. Both LEDs CR700 and CR710 are permanently on. LED CR710 goes low very briefly upon power-on, then lits up permanently.
  • The USB connector J520 and the additional connector JP1000 from the PC motherboard to the PC interface / PPC board are fully and correctly inserted. The Front Panel passes all tests when tested with the Tektronix test application "FrontPanelTest.exe" as found in the /program files sub-directory.
  • The LCD panel and the touch screen work well. All LEDs on the Front Panel light up for several seconds after power-up and then switch off permanently.
  • I have followed the Tektronix Service Manual 071-1004-02 and worked my way through the troubleshooting tree in figure 6-24 in the Service Manual. It basically ends at the last branch "Oscilloscope Application Starts?" Nope....
  • I have measured the power supply voltages per Table 6-5 and 6-6, all voltages measured nominal.
  • I have also removed the PC interface / PPC board and soldered test leads to the power supply section, and the +5V, -5V and +15V and -15V supply rails measure 5.53V, -5.4V, +16.4V and -16,3V DC. Tested the fuses F1001 and F1002, voltages are 5.08VDC on both sides each. The oscillator Y1700 produces a 14.3 MHz clock signal with 3.3Vpp signal amplitude. TP701 near U720 shows a 4.52 MHz clock signal with 3.5Vpp amplitude.
  • All other testpoints on the PC interface/PowerPC board measure static low or 3.3V high.
  • I have evaluated what happens if I press the RESET button on the PC interface / PPC board, same as grounding the test points TP1102 and TP1103 in Figure 6-27 in the Service Manual. No change.
  • Set the test jumper J1100 to force permanent power-on, no change.
  • The +5VA_unreg and -5V_unreg pins on the multi-pin interconnect between the PPC board and the acquisition board measure +5.42VDC and -5.48VDC.
  • I have connected a 9-pin sub-D connector cable to the serial debug port J1050 close to the printer port, pins 2 and 8 (yes, two and eight) show no signal, but are permanently low at -9.8VDC.
  • I had removed the acquisition board, which made no difference.
Software troubleshooting:
  • I have checked all points per the "If the oscilloscope Application does not work" section on page 6-47 on the service manual, no change.
    The Tektronix VXI-11 server runs and is visible in the task bar. This was the case with the Windows 2000 OS and is the same with the Windows ME OS.
  • I have removed and re-installed the two latest Tekscope applications version 1.1.5 and 1.2.1; one after de-installation of the other- no change.
  • In the Windows device manager. I have removed and installed all Tek-specific drivers for the graphics card, changed the drivers for the PCI-to-PCI bridge and the Tektronix IO processor same as for the National Instruments PCI-GPIB adapter. All drivers were taken from the local c:\Tektronix directory. I have tried alternative drivers for the Tektronix IO board... No change.
  • I have restored the original BIOS setting using the "EAAP18EB" tool as found in the c:\Tektronix directory. Same for the c:\Tektronix\CMOS tool, which I ran as "CMOS r -net" No change.
  • I have carefully checked for any resource conflicts on the PC side/Windows Device Manager, and found no conflicts on DMA channels, IRQs or memory space.
  • Screen resolution is set to 640 x 480, 16-bit color depth as per the Service Manual. Verified that the correct display adapter driver is used, as provided in the Tektronix subdirectory.
  • The GPIB port is not responsive and the lower VGA output produces the same signal as the internal LCD.
  • TekVISA finds two resources, ASRL1::INSTR and ASRL2::INSTR - but these are just regular serial COM port aliases, so no sign of any real instrument detection.

MiMatt
Posts: 5
Joined: October 19th, 2017, 9:22 am
Country: United Kingdom

Re: Tektronix TDS5054 oscilloscope repair - PC interface board hangs

Post by MiMatt » November 1st, 2021, 6:20 am

Update:
  • No positive news on the PC interface board, which remains "dead" in terms of the permanently ON LEDs and no communication with the ACQ board hardware. I am reflowing most solder connections and I am probing a few more components on the PC Interface board, but no joy until now
  • A kind soul has generously offered me some help. Let's see...
Cheers,

Matt

MiMatt
Posts: 5
Joined: October 19th, 2017, 9:22 am
Country: United Kingdom

Re: Tektronix TDS5054 oscilloscope repair - PC interface board hangs

Post by MiMatt » November 19th, 2021, 12:43 pm

Good Day,

I am very happy to let you know that after the Power PC/PC interface board was replaced, this baby is back to work again! It works fine with TekScope "Firmware" or program release version 1.1.5.

Those interested in the details may read the full story here: https://www.eevblog.com/forum/testgear/ ... ard-hangs/

A million thanks again to the kind fellow, who has helped me with this!

Cheers,

Matt

Post Reply

Return to “Other or Discontinued Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 1 guest