Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Problem TDS210 Scrolling lines on LCD display

Questions in this forum area are community supported. Tektronix does not regularly monitor posts in this area.
Post Reply
betogreen
Posts: 1
Joined: November 22nd, 2016, 1:48 pm
Country: Canada

Problem TDS210 Scrolling lines on LCD display

Post by betogreen » November 22nd, 2016, 1:54 pm

Does anyone know what might be the cause of horizontal dark lines flickering on the LCD display on a TDS210.
also if I look at the 1kHz test signal on both CH1 and CH2 the bottoms are flat but the tops are modulated with 125Hz noise.

The lines seem to go away when its powered up for more than 10 min, but the CH1 and CH2 125Hz noise is still there. I am wondering if something is about to fail...or if its a simple fix like replacing a capacitor somewhere....

carlvanwormer
Posts: 5
Joined: March 6th, 2014, 3:16 pm
Country: United States

Re: Problem TDS210 Scrolling lines on LCD display

Post by carlvanwormer » June 26th, 2018, 9:03 am

I have the same symptoms. It correlates with the ambient temperature sensing voltage for adjusting the bias/contrast on the LCD. R145 is a thermistor, which is biased from the -24V supply through R146 (6.8k). After heating and cooling the system to remove and reveal the effect, I found that I could make the problem continuous by paralleling R146 with a 10k resistor, bringing the room-temp sensing voltage from 16V up to 18V, significantly reducing the contrast, but exaggerating the line-noise effect. I have to stop this work to do real work for a while, but I hope to find (and share) a solution . . .

carlvanwormer
Posts: 5
Joined: March 6th, 2014, 3:16 pm
Country: United States

Re: Problem TDS210 Scrolling lines on LCD display

Post by carlvanwormer » June 27th, 2018, 9:14 am

Success!
I replaced the three 3.3uF, 35V caps on the back of the display module. The original caps measured around 3uF, but had ESRs in the range of 50 to 70 Ohms (@1kHz). I had some 4.7uF, 63V caps in my parts bin that measured around 5 Ohms ESR, and they were small enough to fit in those locations, so I swapped the original caps for my caps. The problem no longer occurs, even with my extra 10k resistor that exaggerated the original problem.

I realize that this fix it 2 years late for the original betogreen request for help on the power-up problem, but I hope it helps.

Later,
Carl

itullis
Posts: 1
Joined: February 2nd, 2019, 2:46 pm
Country: United Kingdom

Re: Problem TDS210 Scrolling lines on LCD display

Post by itullis » February 2nd, 2019, 2:49 pm

Thank you Carl,

I have the same symptoms, saw your post, replaced the three capacitors and now good as new.

Thanks,

Iain

Post Reply

Return to “Other or Discontinued Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 2 guests