Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

TDS 3054C Front Panel Repair

Questions in this forum area are community supported. Tektronix does not regularly monitor posts in this area.
Post Reply
project-pegasus
Posts: 2
Joined: April 26th, 2018, 12:03 pm
Country: United States

TDS 3054C Front Panel Repair

Post by project-pegasus » April 26th, 2018, 1:11 pm

I'm trying to repair a TDS3054C I - up at an auction. It powers up and passes all self tests but none of the front buttons or knobs work. There's no voltage at the front 5VDC test output and the BNC pads that output +5V and -5V are in spec but the pads that should output 15V are dead, no voltage. After tracing the voltage source for those pads I found they go to pin 2 on J100 of the front button circuit board. That wire goes to pin 2 of J700 on the main board. When I looked closely at J700 I noticed there was solder bridging across pins 1 and 2:
https://imgur.com/JyQBvl3
Is this normal?
The front button circuit board looks new (it has an updated Tektronix part number on it and manufacture date of 0817) leading me to believe the previous owners replaced it in an attempt to fix the same issue.
I'd appreciate any help you can offer.
Thanks.

fenugrec
Posts: 75
Joined: January 18th, 2017, 3:51 pm
Country: Canada

Re: TDS 3054C Front Panel Repair

Post by fenugrec » April 27th, 2018, 7:30 am

project-pegasus wrote:
April 26th, 2018, 1:11 pm
I looked closely at J700 I noticed there was solder bridging across pins 1 and 2:
Certainly looks unusual, but could be normal. You could try removing that solder blob and seeing if there is indeed a trace connecting the two pins anyway, or continuity between them (with the connector unplugged to rule out a short downstream).

Can you probe the 15V pins with the front pannel disconnected ? Again to rule out a short and see if the supplies are working fine.

project-pegasus
Posts: 2
Joined: April 26th, 2018, 12:03 pm
Country: United States

Re: TDS 3054C Front Panel Repair

Post by project-pegasus » April 30th, 2018, 12:42 pm

I checked the voltages on the J700 connector head of the main board and found that Pin 1 has 16VDC but Pin 2 has OV. Even though there's continuity between the two pins number 2 has no voltage, and I would assume that the solder bridge was someone's attempt at sending 15V to Pin 2 on the J100 front board. Also, since I didn't know the pinout for J700 I just started probing with the DMM to find the ground pin and when I shorted pins 1 with 2 the whole unit went into a restart. I didn't mention this in my first post, but when the scope starts up there is some very audible clicking like mechanical relays opening and closing. Does anyone have a pinout for J700 on the main board? I've noticed that the connectors changed a bit from the early TDS 3000s to the later 3054c.

Post Reply

Return to “Other or Discontinued Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 6 guests