Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Disappearing waveform on TDS520

Questions in this forum area are community supported. Tektronix does not regularly monitor posts in this area.
Post Reply
FalconPL
Posts: 1
Joined: November 12th, 2018, 10:58 am
Country: Poland

Disappearing waveform on TDS520

Post by FalconPL » November 12th, 2018, 11:16 am

1. I've done my homework
Hi guys,
I bought a dead Tektronix TDS520 500MHz Oscilloscope for $60 (yup!) and I brought it back to life after reading everything I could ever find on the Internet regarding TDS520 or TDS540.

2. But still
Anyway, despite my efforts I’m still getting:
Acq/Proc interface FAIL
and
Acquisition FAIL
at boot up and I’m also getting a FAIL when I try to perform the SPC (signal path compensation) procedure.

The error log, as read using GPIB, shows just "ERROR: diagnostic test failure, acqdtaconf, ** addr = 0x7300000 exp data = 0x7fff actual = 0xffff, *** WAS TESTING DIG A ***"

3. Waveform intermittently disappears
Interestingly, only once in every 3-4 boot ups I can see the waveforms on both channels A and B and the scope seems to be working correctly (although still with the same errors and probe treated as if it was a x1 one). On the other boot ups, I see no waveform on any of the channels, just the grid.

4. What I've done so far
I’ve recapped all boards and repaired tracks in (hopefully) all layers of the PCB where a cap exploded and left an ugly hole. I’ve also washed everything a couple of times using lots of isopropyl alcohol and ESD safe brush. Apart from that, NV RAM was replaced with a brand new one and everything was reset to factory defaults (yes, I’ve also deleted the calibration values after making a backup of them).

I even tried to swap the original acquisition board with the one from TDS540 but at boot-up the scope protested that it can see 4 channels whereas it’s been designed for 2. The error stated ‘hardware incompatibility’ or something like that. If you know a way to trick it into working with a TDS540 acq boards, please let me know.

Anyway, before I start desoldering ICs at random (to replace them and/or check traces that run underneath them), I thought I’ll ask you guys for advice. Maybe this intermittent problem with waveform display will be particularly helpful at arriving at the cause? Please help.

5. What the voltages look like
I’ve also measured voltages on all caps and most ICs on the Proc and Acquisition boards.
In most cases it’s 5.1V, 10V, 15V or 30V, so normal, I assume. Also, if somewhere it’s 4.9V, I guess it’s acceptable.

I’m attaching photos of both boards, where I marked components which voltages seem dubious to me. Maybe they’re normal, I have too little experience with these scopes to tell, but they definitely differ from the voltages mentioned above.
acq.jpg
acq.jpg (1.87 MiB) Viewed 938 times
acq.jpg
acq.jpg (1.87 MiB) Viewed 938 times
Attachments
proc.jpg
proc.jpg (1.97 MiB) Viewed 938 times

strick
Posts: 95
Joined: March 22nd, 2016, 11:23 am
Country: United States

Re: Disappearing waveform on TDS520

Post by strick » November 12th, 2018, 12:46 pm

FalconPl,

The main error points to a memory fault in the Acquision memory on channel 1. Unfortunately, you could have one bad chip or dozens - you don't know until you start at the first failure and then turn it on again. These chips can fail on their own, but they are especially susceptible to static discharge. Make sure you use static precautions!

I can tell you that when I had memory problems that were solved by replacing the memory chips, SPC ran fine. You probably have other problems too. Actually, some folks have had reported that they had memory errors with failed or disconnected components in the acquistion timing or other components on the board.

I would mess with the cmos static ram only as a last resort. Been there, done that. Plus, you have the 1M chips (7164) with the old style (NOT SOJ) that are just about impossible to find at the 25 ns speed rating. You can find the SOJ, but then you have to bend the contacts out to hit the pads. Not a fun job

I've a couple of 520 or 640 boards that I've fixed with multiple problems. Past about 4 or 5 fixes, the board will likely cause problems off and on forever.

A couple of questions:
do you have the TDS520 Service manual Vol 2: Component Level Diagnostic and Repair manual?
do you have a serial output (debug) connector?

Without some idea of where you had the caps leaking and the repairs that you did, it's hard to diagnose what could be wrong.

You might send me a PM if you would like more pointed information.

Strick

Post Reply

Return to “Other or Discontinued Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 4 guests