Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

AWG 615: Logic Jump Behavior?

Questions in this forum area are community supported. Tektronix does not regularly monitor or guarantee responses in this area.
Post Reply
oscopeuser77
Posts: 1
Joined: November 18th, 2016, 11:11 am
Country: United States

AWG 615: Logic Jump Behavior?

Post by oscopeuser77 » November 18th, 2016, 11:53 am

I am seeing unexpected behavior using SEQuences with logic jumps on an AWG 615.

I have a SEQuence of 20 WFM files, with logic jumps specified for each line. Each line is also set to "Wait for Trigger". I am using "Logic" jump mode and "Async" for jump timing, with "Strobe" enabled. Right now I am just using the internal trigger of the AWG 615. Here's my problem:

When I provide the correct logic to the pin inputs and set the strobe line low, the AWG 615 *only* registers the event if the strobe line goes low DURING the output of a WFM in the sequence. If I externally set the logic pins and send the strobe during a gap between WFMs, the logic jump/event does not register at all, and the SEQuence continues without executing the logic jump.

Is this expected behavior? The user manual PDF (pg 250) says,
"Selecting ASync causes the instrument to jump to the specified sequence table line as soon as an event goes true"
"When Strobe is set to On, the instrument reads the event signals when the strobe goes to low state (Enable), and updates the event value if a state transition in the event signals are found".
In my application, I'd like to use an external microcontroller to trigger the playback of a single WFM in the SEQuence, let the microcontroller perform some processing/calculations, after which the microcontroller may (or may not) drive the logic pins/strobe pin on the AWG 615 to a true state. Ideally, the AWG 615 would register that as a logic jump and jump to the specified line (per the SEQ file), even if it's just "idling" as it waits for a trigger for the next line.

As it stands, it sounds like I'll have to create blank "dummy" WFM files for each real WFM file that will play when the microcontroller is ready to trigger a logic jump. I guess that would work, but it will eat up quite a bit of memory in the form of blank WFMs if I have to do that. Any better solutions out there?

Post Reply

Return to “Older and Obsolete Signal Sources”

Who is online

Users browsing this forum: No registered users and 2 guests