Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

MDO4054-6 Hung at Splash Screen

Post Reply
Posts: 1
Joined: January 13th, 2020, 6:50 am
Country: United States

MDO4054-6 Hung at Splash Screen

Post by JohnRB » January 13th, 2020, 10:49 am

I have owned the subject scope for about 8 years and it recently would hang at the splash screen at power on. The covers had never been removed since I purchased the scope. I did not want to spend a lot of money getting it repaired so I decided to try and troubleshoot it myself.

I removed the rear covers, powered on the scope and measured all of the voltages at the provided test points. Everything was fine except for +1.5V which was at zero. I examined the PCB on both sides near the +1.5V test point and could not find any traces leading to a power source - could be an internal plane. Either my version of the scope did not use +1.5V or this was the problem.

After finding nothing else of interest I put the scope back together and turned it on again, IT WORKED. I then power off the scope and turned it on again and it hung with the splash screen as before. I disconnect AC power for a short period of time and tried it again, still hangs. I disconnected AC power and left it that way overnight. The next morning it power up fine again, but failed at the next power off/power on sequence.

I opened the scope again and added test wires for +5VSB and +1.5V. I closed everything back up with the test wires exiting the case so I could access them. I wanted to see if +1.5V was present when the scope was working and also measure how long it took for +5VSB to get to 0V after AC power was removed.

I powered the scope back on with meters connected to both test leads. The scope powered up fine and +1.5V was at 0V so it appears that the MDO4054-6 does not use +1.5V.

I powered the scope off and then back on again expecting it to fail. It powered on just fine. There was no need to see how long it took for +5VSB to get back to 0V.

I was quite sure that something was not getting properly reset when +5VSB remained active.

The I/O board mounted on the rear case cover has 3 connections. One for AC (power line sync), one for fan power and a large card edge connector which plugs into what I believe is a PCI Express socket on the main acquisition board. This card edge connector is unplugged automatically when the rear cover is removed. My guess is that the PCI Express socket using normal wiring and that the Power On Reset (POR) is on that connector at pin A9 (I have not verified that). If the contact for that pin was not proper then only one of the boards (I/O board or main acquisition board) would be receiving a POR. However completely removing AC power and letting the +5VSB get to 0V would allow everything to reset properly. I suspect that the multiple removal and installation of the rear scope case (including the card edge connector) wiped the PCI Express pins enough to now make good contact.

Scope is still powering on and off just fine and hopefully it will remain that way.

Hopefully this post will help others if they encounter the same issue.


Post Reply

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests