Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

2380 IVI driver help

Series 2380 DC Electronic Loads
Post Reply
misko85
Posts: 2
Joined: July 3rd, 2020, 4:41 am
Country: Yugoslavia

2380 IVI driver help

Post by misko85 » July 3rd, 2020, 4:47 am

Hello everyone,

I have a problem using IVI drivers for 2380-500-30 in LabWindows/CVI IDE. I've successfully loaded the instrument (.fp file) into project, but each time I try to set some parameter, device goes to error mode (ERROR mark is activated on display), which cannot be cleared until the device power is cycled. I managed to read measurements without any problem, but each time the command is sent it goes to error. Does anyone have any sample code I could use? The examples which came with the drivers are covering only .dll implementation. Thanks!

Miodrag

misko85
Posts: 2
Joined: July 3rd, 2020, 4:41 am
Country: Yugoslavia

Re: 2380 IVI driver help

Post by misko85 » July 3rd, 2020, 6:23 am

I've detected possible source of the problem. The device has to be activated in Remote operation mode, but the command is ignored when I try to do so using keyboard commands. I cannot find any function in instrument .fp driver which activates Remote mode...

Post Reply

Return to “Electronic Loads”

Who is online

Users browsing this forum: No registered users and 1 guest