Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Trouble setting channel functions

DAQ6510 6½-Digit Data Acquisition and Logging Multimeter System
Post Reply
TonyArc
Posts: 1
Joined: January 14th, 2021, 11:47 am
Country: United States

Trouble setting channel functions

Post by TonyArc » January 14th, 2021, 12:02 pm

I'm working on a testing system that uses Python to control a DAQ6510 via ethernet. I recently changed the control computer from an obsolete variant of Linux to Windows. This caused a new incompatibility between pyvisa and multithreading. In order to avoid a full rewrite of the test code, the system is now opening a socket at the beginning of each command and closing it after. The problem I'm facing is that the command to set the channel functions doesn't seem to stick. The core of the command set is shown below:

*RST
SENS:FUNC 'CURR', (@141, 142)
SENS:CURR:RANG 10e-3, (@141, 142)
SENS:CURR:AZER ON, (@141, 142)
SENS:CURR:NPLC 1, (@141, 142)
SENS:CURR:DELAY:AUTO ON, (@141, 142)
SENS:FUNC? (@141, 142)
Received: NONE;NONE

I've tried changing the type of quotes on the function, the channels, the function type, the encoding of the data, and the EOL termination, to no effect. I even used a network sniffer to see if something was getting scrambled, but everything looks ok to me. It seems that other commands are working fine, but this command is rather important.
network_log.png
network_log.png (5.47 KiB) Viewed 101 times
Edit: I've also tried the command using the browser interface and it works fine.

Post Reply

Return to “DAQ6510 Data Acquisition and Logging Multimeter System”

Who is online

Users browsing this forum: No registered users and 1 guest