Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

DMM 2701 missing triggers?

Post Reply
taurel
Posts: 9
Joined: January 9th, 2013, 1:43 am
Country: France

DMM 2701 missing triggers?

Post by taurel » March 2nd, 2014, 11:54 pm

Hello all,

We are using Keithley DMM 2701 in DC voltmeter mode. It is externally triggered by a 10 HZ hardware signal. When the trigger is received,we want 10 measurements. The measurements are then sent to the buffer which is configured to store the measurement value, the timestamps and the record number. The buffer is configured as a circular one with 2000 values. We set the NPLC in order that each measurement takes 9 mS (NPLC=0.45 for 50 Hz). After 10 measures , we should have 10 mS for the Keithley to wait for the next trigger (100 - (10 * 9)). Our problem is that the DMM miss some triggers. During a run of 50 mins, we have recorder 7 occurrence of this trigger missing.
After reading the data out o fthe buffer, we compute and print the delta t between measurement. Here is a case when the trigger has been missed:

delta_t (msec) = 9.241
delta_t (msec) = 11.989
delta_t (msec) = 11.616
delta_t (msec) = 10.131
delta_t (msec) = 9.67
delta_t (msec) = 13.412
delta_t (msec) = 10.014
delta_t (msec) = 9.247
delta_t (msec) = 9.23
delta_t (msec) = 106.044
delta_t (msec) = 9.244
delta_t (msec) = 9.237
delta_t (msec) = 9.242
delta_t (msec) = 9.245
delta_t (msec) = 9.235
delta_t (msec) = 9.243
delta_t (msec) = 9.238
delta_t (msec) = 9.233
delta_t (msec) = 9.233

Three remarks about these readings.
1 - After the missed trigger, it's clear that each measurement takes 9.2 mS instead of 9 (0.45 * 20)
2 - Before the missed trigger, the DMM seems to be desynchronized because the measurement takes 11, 10, 13 mS!
3 - Finally, a trigger is missed

Do you have any idea of what could be the reason of this behavior?

Thank's for your answers

Emmanuel

PS: Commands sent to the DMM to initialize it:
SYST:PRES
VOLT:RANG 10
VOLT:AVER:STAT OFF
VOLT:NPLC 0.45
FORM:ELEM READ,TST,RNUM
TRIG:DEL:AUTO OFF
INIT:CONT OFF
SAMP:COUN 10
TRIG:SOUR EXT
TRAC:CLE
TRAC:TST:FORM ABS
TRAC:POIN 2000
TRAC:FEED SENS
TRAC:FEED:CONT ALW
SYST:AZER:STAT OFF

AND commands to get data out of the buffer:
INIT
then in a loop
TRAC:NEXT ?
TRAC:DATA:SEL ? xx yy

Norbert W
Keithley Applications
Keithley Applications
Posts: 227
Joined: October 21st, 2010, 7:18 am
Country: Germany

Re: DMM 2701 missing triggers?

Post by Norbert W » March 10th, 2014, 6:24 am

Hello Emmanuel,
I have some comments which hopefully will help to solve your problem.
The actual time between measurements is a little bit longer as calculated from NPLC/line frequency because of a minor last step in the A/D conversion and because
of firmware overhead.
The more important aspect is that despite using a dual ported RAM the actual data transfer will slow down the rate of (simultaneously) taking new measurements. It will not be much
but noticable.
So you might consider the rate of getting data or the amount of getting data being of influence here.
Generally (if applicable to your signal) you might also consider to reduce the NPLC setting in order to get more time between measurements and a new trigger.
Best regards
Norbert

Jeremy
Posts: 1
Joined: August 19th, 2015, 7:04 am
Country: United Kingdom

Re: DMM 2701 missing triggers?

Post by Jeremy » August 19th, 2015, 7:42 am

Hi
We have a simillar problem though in our case the aquisition and reading of DMM buffered measurments are not performed at the same time so should not casue a problem. We are using a 2701 DMM and 7702 mux to acquire voltage measurements with ~ 10ms interval in response to the external trigger signal, we trigger the DMM 32220 times but randomly it will return about 30 measurements less than expected. Looking at the time taged measurements that are returned 6 of them have delta from previous measurement of >= 20 ms and one had a 250ms delta (and the sum of the extra time seems to account for the missing measurements). Our NPLC is set to 0.1 (2ms equivalent) so there should be plenty of time for the measurement to complete. We have cheked the trigger signal on a scope and its period never exceeds 15ms or is less than 10ms and has good voltage levels what could be causing this problem (2701 firmware ver D05).

Post Reply

Return to “Series 2700 Multimeter/Data Aquisition/Switch System”

Who is online

Users browsing this forum: No registered users and 3 guests