Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Can't interface 2700 to PC via RS232 USB

Post Reply
anovogra
Posts: 1
Joined: September 9th, 2016, 12:23 pm
Country: United States

Can't interface 2700 to PC via RS232 USB

Post by anovogra » September 9th, 2016, 12:59 pm

I want to interface an older Keithley 2700 with a 64 bit Windows 7 PC using a RS232 to USB converter. When using Keithley Configuration Panel, I get the following message: "This Wizard found a physical device at the hardware resource you specified, but the device did not return an ID string."

Within the last 48 hours I have downloaded/installed:
Kickstart
Keithley Communicator
Keithley Configuration Panel
Drivers for 3 different USB/RS232 converters
I also attempted to download/install "Integra Up&Running TestPoint Runtime Software", but when I tried to install, it said that it was incompatible with 64 bit. I had hoped to get the KE 2700 driver that way, but the 64 bit thing is a problem.

The 2700 is set with the RS232 "on", 9600 baud, Flow = XonXoff, and I have tried all 4 settings for Tx Term.
The Port is set to COM1 (although I have tried 2 and 3 also), 9600 baud, Flow = XonXoff, Data bits 8, Parity none, stop bits 1.
Configuration Panel is set to Serial Com1, 9600 baud, Flow = XonXoff, and the instrument model is set to KESCPI-Any.
I have been told that Kickstart won't talk to the RS232, even when converted to USB, so I was hoping to access the 2700 using Keithley Communicator.

The fact that the Configuration Panel tells me that it can detect a device gives me hope, but it obviously isn't successfully communicating with the 2700. Two out of three of the USB/RS232 converter cables succeeded in getting the error message above. One of them couldn't even get that. The 2700 manual says it uses SCPI communication, so I figured the "KESCPI-Any" setting would be ok for the driver. Is there a setting on the 2700 itself that I need to modify to get it to send its ID to the software and communicate? I do not have Labview, and have no desire to go that route.

I would really appreciate any help I can get on this.

Dale C
Keithley Applications
Keithley Applications
Posts: 2845
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: Can't interface 2700 to PC via RS232 USB

Post by Dale C » September 12th, 2016, 6:06 am

What port is the USB to RS-232 on ? COM 1 , COM2 ? etc.
When you know that, use the Keithley configuration panel to "add" a new device. And make the RS-232 proper COM port.
Also match the settings of the 2700 serial port (BAUD, FLOW and Terminator) to the COM port on the PC.
if you can do this in Configuration Panel then it should work in Keithley Communicator.
Sometimes with the USB to RS-232 adapters the COM ports are higher than the default of the Keithley CONFIG panel.
Use this procedure to correct the COM port.

How to set up COM port names higher than 4.
Although 4 com ports are listed, you can modify any single com port using the Keithley Configuration Panel, Here's how to change COM1 to COM15 as follows:


Close Excel and ExceLINX (if open)


Open the Keithley Configuration Panel (Start -> All Programs -> Keithley Instruments -> Keithley Configuration Panel)


Select the Wizard and press Cancel button to exit the wizard


In the list of Instruments presented on the Instruments Tab, select KE2700_COM1
Right mouse click and rename from KE2700_COM1 to KE2700_COM15
Press the + Sign to the left of the listing to expand its tree
Selelect COM1 and right mouse click to rename from COM1 to COM15
Press the + sign next to COM15 to further expand the tree
Click on ASRL1::INSTR. Right-mouse-click and select rename: rename to ASRL15::INSTR
On right side of pane double click on field SystemName and edit to change from COM1 to COM15
Exit the Keithley Configuration Panel and save your changes!


Open Excel and create new ExceLINX DMM Config and DMM Scan pages.
On the DMM Config page, on row 12 select the device KE2700_COM15 then attempt to detect device and see if you can communicate. Be sure that all settings for ASRL15::INSTR in the configuration panel match those of your instrument too (9600 baud, flow control none, tx term CR).

Post Reply

Return to “Series 2700 Multimeter/Data Aquisition/Switch System”

Who is online

Users browsing this forum: No registered users and 2 guests