Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Occasional Connecting Error Ethernet

Post Reply
MarioHubert
Posts: 1
Joined: October 15th, 2019, 1:29 am
Country: Germany

Occasional Connecting Error Ethernet

Post by MarioHubert » October 15th, 2019, 1:56 am

Hello everybody!

I'm using a Keithley model 2701 to make periodical voltage measurements. The Keithley connected to the pc via an ethernet connection and controlled by a LabView program. Roughly every minute, several (three) voltage measurements are made in a row by repeatedly running a sub VI that comunicates with the Keithley. In each measurement the Keithley is initilized at the beginning and closed after the read task is finished.
This works most of the times, but after an unpredictable time (typically from several hours to several days) of running the LabView program, the communication between the PC and the Keithley fails. When this happens, it is not possible to communicate with the Keithley anymore with the measurement and automation explorer. After switching the Keithley off and on again, communication between the PC and the Keithley is once again possible.
Can you give me advice on what could be the reason for the occasional communication failures, and how I could fix this issue?

Thank you and best regards!
Mario

Post Reply

Return to “Series 2700 Multimeter/Data Aquisition/Switch System”

Who is online

Users browsing this forum: No registered users and 1 guest