Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

PS280 Lab Power Supply

Post Reply
dorbie
Posts: 3
Joined: November 27th, 2014, 12:56 am

PS280 Lab Power Supply

Post by dorbie » November 27th, 2014, 1:59 am

Hi,

I just acquired a used PS280. I have tested the DC voltage from it and it looks good across the +ve and -ve terminals on each of the three rails. However if I measure the potential relative to ground I see about a ~8 volt (peak) noisy ~60Hz AC wave. So both +ve and -ve terminals have the same AC wave relative to ground but the waves are separated in potential by a smooth DC voltage. My question; is this normal for this supply? I expected something more stable relative to ground.

I searched these forums and saw one post on the PS280 saying this is a rebranded GW Instek product.
Does anyone know what the equivalent product number from GW Instek is?

dorbie
Posts: 3
Joined: November 27th, 2014, 12:56 am

Re: PS280 Lab Power Supply

Post by dorbie » November 27th, 2014, 2:05 am

P.S. To answer my own second question I think this is the GW Instek GPC-3030D.

I'd still welcome any opinions on the issue of the AC wave relative to ground on all outputs.

dorbie
Posts: 3
Joined: November 27th, 2014, 12:56 am

Re: PS280 Lab Power Supply

Post by dorbie » November 27th, 2014, 2:34 am

P.P.S.

After downoading and reading the operating manual I have learned that you can operate in several modes, I think I am in floating mode and what I want is ground referenced mode which for my use involves connecting the -ve terminals to ground.

I did not expect to see such a big potential oscillation in floating mode but discovering that I can ground reference is great news.

rsudjian
Posts: 131
Joined: January 19th, 2011, 2:43 am

Re: PS280 Lab Power Supply

Post by rsudjian » December 13th, 2015, 12:14 pm

I have never liked the design which keeps the cooling fan on even with no load.
I designed a simple circuit with a mosfet, potentiometer, and three thermistors
with negative temperature coefficient. I epoxied the thermistors into yellow spade
lugs and attached them to the three power transistors on the central heatsink.
System works great. When I hold one of the lugs between my fingers the fan
starts within 2-3 seconds and increases in speed as the resistance drops.

http://i128.photobucket.com/albums/p189 ... C_0726.jpg
http://i128.photobucket.com/albums/p189 ... C_0728.jpg

Post Reply

Return to “Other Power Supplies”

Who is online

Users browsing this forum: No registered users and 3 guests