Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

KUSB-488B and Windows 10

Post Reply
id3691
Posts: 5
Joined: October 24th, 2018, 1:13 am
Country: Romania

KUSB-488B and Windows 10

Post by id3691 » October 24th, 2018, 1:40 am

Kusb-488B cannot run with the driver KI-488_v3.13.1_KI-488-3.13.1 in windows 10 64 bit.
”KI-488 Diagnostic Tool” doesn't start. It shows the message: ”Run-time error 48 IEEE_32M.dll file not found” when start initialization for address 21.
When start ”KI-488 Configuration Utility” the message is ”the application was unable to start correctly (0xc000007b)”. :(

Stuart M
Keithley
Keithley
Posts: 412
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KUSB-488B and Windows 10

Post by Stuart M » October 25th, 2018, 12:55 pm

The KI-488 Configuration Utility is the most important of the tools.
If this is not working, something is not correctly installed.

Has this system ever had a previous version of the KUSB-488B driver?
Does it have any other GPIB drivers installed? If so, then they need to be uninstalled.
Often this can occur when other products are installed.
For instance, open the control panel -> programs and features
and click on National Instruments Software, and then click on uninstall/change and
look at the list of drivers to see if NI-488.2 is listed. If there are NI-488.2 entries, they all need to be uninstalled and reboot.

I would then uninstall the Keithley KUSB-488B driver and search the entire hard drive for all copies of gpib-32.dll and delete them too.
Then, reboot and reinstall the KI-488 3.13.1 driver as NI Command Compatible. After the driver and reboot the computer then connect the KUSB-488B, allow it to connect the loader, then run the KI-488 Configuration Utility again.

Let me know your results in this posting...

id3691
Posts: 5
Joined: October 24th, 2018, 1:13 am
Country: Romania

Re: KUSB-488B and Windows 10

Post by id3691 » October 25th, 2018, 10:59 pm

Yes, the KI-488 Configuration Utility and KI-488 Diagnostic Tool are the most important to check the proper operation of the KUSB-488B.
That's why I called your support.

The computer I'm working on is new, but I tried to install the KUSB-488A interface that I had earlier.
It did not work and I found out that the software for it does not develop anymore. I uninstalled the driver at that time.
So, I bought the KUSB-488B.

Now, I have uninstalled all gpib drivers. I have deleted all the copies of the gpib-32.dll files that still existed in my developed softwares.
I checked Registry (regedit) and I do not have any gpiv-32 or KUSB keys.
I restarted the PC.
I installed KI-488_v3.13.1_KI-488-3.13.1 with the NI Command Compatible option - at the end of the installation I restarted the PC.
I connected the KUSB-488B interface.

I started the KI-488 Configuration Utility and the message "The code execution can not proceed because gpib-32.dll was not found" appears.

When I start the KI-488 Diagnostic Tool and press "Initialize KI GPIB" a window appears with the GPIB card address selection.
I left the default 21 address and I pressed OK. The error message "Run-time error '53' appeared. File not found IEEE_32M.dll "and the application closes.

I installed the same driver also on another computer that has Windows 10 Ver 1803 64-bit used for text editing only - no GPIB driver or something similar has ever been installed.
Behavior is the same (the same messages appear).
Attachments
Capture1_2.PNG
Capture1_2.PNG (56.27 KiB) Viewed 1249 times
Capture1_1.PNG
Capture1_1.PNG (58.04 KiB) Viewed 1249 times
Capture.PNG
Capture.PNG (22.62 KiB) Viewed 1249 times

Stuart M
Keithley
Keithley
Posts: 412
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KUSB-488B and Windows 10

Post by Stuart M » October 26th, 2018, 11:56 am

Did you install the driver with the Anyone who uses this computer or with the Only for me option?
I am now seeing a problems with the other "Only for me" option.
Please uninstall and reinstall with the "Anyone who uses this computer option" while we debug the problem.
Also, are both your win 10 computers using build 1809?

id3691
Posts: 5
Joined: October 24th, 2018, 1:13 am
Country: Romania

Re: KUSB-488B and Windows 10

Post by id3691 » October 29th, 2018, 12:04 am

I have installed the driver so far with the option "Only for me".
So, I uninstalled the driver and reinstalled it with the "Anyone who uses this computer option" option.
At the end of the installation, I restarted the PC.

I connected the KUSB-488B interface to the computer.

The pleasant surprise was that the error messages were gone
when starting "KI-488 Configuration Utility" and "KI-488 Diagnostic Tool" applications.
In the attachment are the captures of these applications for the case
when KUSB-488B where connected to the computer and
without measuring device connected to the KUSB-488B - It seems OK now.

The computer we did all the tests is Windows 10 Ver 1809 64-bit.

The other computer used for editing is Windows 10 Ver 1803 64-bit.
I did the same with this computer. Behavior is the same.

It seems the problem is in the installer software.
We expect in the new driver version to be corrected.

Thank you very much for the technical support provided.
Attachments
KI-488 Diagnostic Tool.png
KI-488 Diagnostic Tool.png (42.44 KiB) Viewed 1072 times
KI-488 Configuration Utility.png
KI-488 Configuration Utility.png (15.07 KiB) Viewed 1072 times

Stuart M
Keithley
Keithley
Posts: 412
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KUSB-488B and Windows 10

Post by Stuart M » October 30th, 2018, 10:32 am

Thanks for your very detailed reports to troubleshoot this problem.
Glad we could get you up and running.
Until a new version of the driver is created, tested and released,
continue to use "Anyone who uses this computer option" to install the driver.

Post Reply

Return to “Instrument Accessories & GPIB”

Who is online

Users browsing this forum: No registered users and 1 guest