Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

KUSB-488B with Visual Studio 2010

Post Reply
walterf25
Posts: 7
Joined: November 27th, 2012, 12:33 pm
Country: United States

KUSB-488B with Visual Studio 2010

Post by walterf25 » November 27th, 2012, 1:57 pm

Hello all, i'm working on a project which requires me to communicate with the Keithley 2750 Multimeter/Switch System, and i have a KUSB-488B cable, i have the drivers installed, i was looking at the .net examples that come when the driver is installed, i tried to run the examples but i get an error all the time when i try to run the program, maybe someone here has came across the same issue and can help me by telling what i'm doing wrong or not doing?
scrshot.jpg
scrshot.jpg (317.97 KiB) Viewed 19744 times
attrached is a - of the error i keep getting, i really appreciate your help in advance.

Cheers,
Walter

Dale C
Keithley Applications
Keithley Applications
Posts: 2840
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: KUSB-488B with Visual Studio 2010

Post by Dale C » November 28th, 2012, 6:35 am

Not sure why you are having issues with Visual Studio and KUSB-488B.
Does the KUSB-488B communicate with the Model 2750?
Try the KI-488 Diagnostic Tool to verify the KUSB-488B is communicating.
Go to START, select All programs.
Select Keithley Instruments
Select KI-488
Select KI 488 diagnostic tool.
Leave GPIB address to 16.
In the GPIB command field type in *IDN?
Now click on the SEND button.
Now click on the ENTER button.
You should see something like
Keithley Instruments Model 2750 sn123456 rev B01

Stuart M
Keithley
Keithley
Posts: 413
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KUSB-488B with Visual Studio 2010

Post by Stuart M » November 28th, 2012, 8:55 am

You might need to rebuild the solution.
Make sure that you check the build configuration settings for a specific CPU type that is supported (e.g. x86 or x64).

This can be found on the "Build" menu, see if you have an item called "Configuration Manager". If not, you need to add the item to the menu (right-click on any area in the toolbar and choose "Customize" at the bottom of the list).

Once you've opened the Configuration Manager dialog, go to the "Active solution platform" drop-down box and choose "New". From the "New Solution Platform" dialog that appears, you should be able to choose "x86" (for example) from the first drop-down box.

walterf25
Posts: 7
Joined: November 27th, 2012, 12:33 pm
Country: United States

Re: KUSB-488B with Visual Studio 2010

Post by walterf25 » November 28th, 2012, 9:39 am

Hi all, thanks for the replies, i actually tried both suggestions, and I still get the same error, i'm not sure what else to do, I really would like to get this working, as I have a very big project to work on here at work, and I need to communicate with the Instrument via GPIB.

I can tell the KUSB-488B works because i can communicate with the Keithlery 2750 using the application that came with the driver, i can get the Meter's model number etc....

Thanks,
Walter

Stuart M
Keithley
Keithley
Posts: 413
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KUSB-488B with Visual Studio 2010

Post by Stuart M » November 28th, 2012, 10:49 am

What version of driver are you using?
The latest version is currently 3.12
http://www.keithley.com/support/data?asset=56984

Also, is it installed as NI Command Compatible or Keithley Command Compatible?

walterf25
Posts: 7
Joined: November 27th, 2012, 12:33 pm
Country: United States

Re: KUSB-488B with Visual Studio 2010

Post by walterf25 » November 28th, 2012, 1:12 pm

I'am using driver version 3.12 and it is installed to use Keithley command mode.

Thanks,
Walter

Stuart M
Keithley
Keithley
Posts: 413
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KUSB-488B with Visual Studio 2010

Post by Stuart M » November 28th, 2012, 2:29 pm

Trying to reproduce your problem but so far no failures here...can you tell me more?

Did the .exe of the VB.NET ReadWrite example run successfully before you attempted to rebuild the solution?
Did the example convert successfully?
Did you do a build or a rebuild? Were there any errors?
Can you try to run the Query Identification example.exe and see if this works and can you try rebuild this example and test it out...?

What operating system/bits & service pack are you using? win 7/32-bit sp1?
What is the platform you selected in the build configuration manager? anycpu? x86?
What is the version of VS Studio 2010 you are using...Professional? Express?

Post Reply

Return to “Instrument Accessories & GPIB”

Who is online

Users browsing this forum: No registered users and 1 guest