Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

KPCI-488LPA & Windows XP Embedded OS

Post Reply
IgorTarasov
Posts: 5
Joined: November 25th, 2010, 2:27 pm
Country: United States

KPCI-488LPA & Windows XP Embedded OS

Post by IgorTarasov » November 25th, 2010, 2:33 pm

Hello,

Sorry to disturb you I have some question about GPIB KPCI-488LPA Interface card. Do you know any limitation on using this card on Windows XP Embedded OS? I have two tools using the identical software (VC++). The same drivers (Keithley command support). The system with XP professional does not have any errors at all, the system on Windows XP Embedded produces multiple hanging-up. I really need your help.

Thank you in advance

Igor

Dale C
Keithley Applications
Keithley Applications
Posts: 2841
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: KPCI-488LPA & Windows XP Embedded OS

Post by Dale C » November 29th, 2010, 6:57 am

What version of the KPCI-488LPA driver are you using?
After looking at the release notes for this driver, I would recommend version 2.0.
It looks like version 1.2 had some bugs fixed that hung up the GPIB.
Here are the release notes for version 2.

Modification of NI-compatible driver in KEITHLEY CD 1.2
-----------------------------------------------------------------

**** Miscellaneous bug fixes ****

* When is in slave mode, a gpib read following a GPIB
write sometimes got stuck.
* When TIMO is set in the wait mask, ibwait returns when the timeout
occures but TIMO bit is not set to ibsta (except the timeout is
caused by GPIB I/O).
* ibwrt is failed when EOS on write is enabled and the write string contains
EOS.
* When a GPIB I/O is in progress, the second GPIB I/O keeps waiting until timeout
instead of directly blocking the second operation.

**** Feature enhancement ****

* Setup program supports Windows 2000/XP/Vista system.

IgorTarasov
Posts: 5
Joined: November 25th, 2010, 2:27 pm
Country: United States

Re: KPCI-488LPA & Windows XP Embedded OS

Post by IgorTarasov » November 29th, 2010, 10:34 am

Hi! Thank you for advice.
But I DID NOT use NI compatible driver. I uses driver from CD originally shipped with card.
I will try to use version 2.0

Stuart M
Keithley
Keithley
Posts: 413
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: KPCI-488LPA & Windows XP Embedded OS

Post by Stuart M » December 1st, 2010, 8:34 am

Actually the latest driver version is now 3.06.
http://www.keithley.com/support/data?asset=52970

Post Reply

Return to “Instrument Accessories & GPIB”

Who is online

Users browsing this forum: No registered users and 5 guests