Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

keithley 6517 error query problem

Post Reply
Ryan Saunders
Posts: 1
Joined: April 2nd, 2015, 8:48 am
Country: United States

keithley 6517 error query problem

Post by Ryan Saunders » April 2nd, 2015, 9:07 am

I’m working on automating the calibration for all of the 6517 Electrometer/High Resistance Meter we have. For the Voffset and Ioffset I would like to make sure that there were not any “could not converge” errors. I have been trying to use the error query vi but not sure what the “source” input should be. Is it possible to retrieve these errors and if so what would be the best way to do it. :?:

Dale C
Keithley Applications
Keithley Applications
Posts: 2842
Joined: June 10th, 2010, 6:22 am
Country: United States
Contact:

Re: keithley 6517 error query problem

Post by Dale C » April 6th, 2015, 8:31 am

The source in the VI is a little odd. By that I mean it is asking for an error input.
This VI sends an error query to the 6517. If it says it has an error then the user inputs in the error in the SOURCE field.
Not sure how this is supposed to work. Maybe for someone writing a driver it would be helpful.
But to just get the errors from the unit, I would recommend using the Status model to see what the errors are.
Look in section 13 of the reference manual of the Model 6517B. That should help.

Post Reply

Return to “LabView Drivers”

Who is online

Users browsing this forum: No registered users and 5 guests