Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

Keithley 2400 Range Compliance Issue

Post Reply
dcooke13
Posts: 1
Joined: August 9th, 2017, 7:20 am
Country: United States

Keithley 2400 Range Compliance Issue

Post by dcooke13 » August 9th, 2017, 7:42 am

Hello,

I am having some issues controlling my Keithley 2400 SourceMeter via LabView. I am supplying ~0-15V to a MEMS device, with current up to ~20mA. When I manually control the power supply, the auto range function works properly and I do not encounter range compliance issues. However, when I run it in LabView, the measurement range does not appear to update automatically, despite Auto Range being set to "on" by ConfigureMeasurement.vi, as well as the presence of the "AUTO" light on the power supply itself. As such, the current exceeds the measurement window and causes range compliance issues.

I've attached a simplified VI that I put together just in an attempt to get continuous variable voltage control working properly when controlling the power supply via LabView.

Ultimately, my issue hinges around one main question: which VIs or VISA commands will cause the power supply to auto update the measurement range properly? I've noticed that including Read.vi inside the while loop will do so, but at the cost of severely slowly down the rate at which I can control the power supply (from >20Hz to 2-3Hz)

Thanks in advance for any advice you can offer!

-Davis
Attachments
Basic Voltage Control.vi
(15.96 KiB) Downloaded 804 times

Post Reply

Return to “LabView Drivers”

Who is online

Users browsing this forum: No registered users and 2 guests