Page 1 of 1

Labview doesn't recognize instrument

Posted: July 6th, 2018, 3:10 pm
by jmentor201016
I have been trying to get Labview to communicate with Keithley Sourcemeter 2401 but labview doesn't see the instrument. The instrument is connected to the PC KUSB 488B GPIB. There's a green light which indicates that it is ready. I am using Labview 2017 (32 bit). I have downloaded Keithley I/O layer, the KUSB-488B driver 3.13.1 (NI compatible version), and the vxiplugandplay driver for the 24xx model series. There's also the NI VISA 18.0 that is also downloaded. I am using Windows 10 with a 32 bit operating system and x64-based processor. I have checked the NI-VISA Interactive Control(see attached) and the instrument isn't there. I tried doing a test through the Keithley Configuration Panel, and again it says that the instrument needs to be connected. I used the Keithley Diagnostic Tool(see attached), it resulted in OK.I went to the Keithley Configuration Utility and the instrument isn't there (see attached). So I'm not sure what to do at this point. I have uninstalled drivers only install drivers. I went back and forth between KUSB driver 3.13.1 (NI Compatible version) and the Keithley Compatible version. the only time that it worked was when I installed KUSB 3.12 driver but that was shortlived. And I'm back at square one. Please help.

Re: Labview doesn't recognize instrument

Posted: July 9th, 2018, 8:25 am
by Stuart M
No matter which version of driver you have if the KI-488 Configuration Utility does not see the instrument, then LabVIEW will not work, nor will NI VISA Interactive...

Check the front panel of the instrument:
Menu -> Communication -> GPIB
- set the address for 24
- set the Protocol for SCPI

Then, remove the usb connector to the pc and reconnect.
Recheck the KI-488 Configuration Utility and see if the results are any better.

If not...let me know the results.
Also, am a bit confused when you say that the version 3.12 driver worked but it was short-lived....did something change with your setup there?

Re: Labview doesn't recognize instrument

Posted: July 9th, 2018, 10:27 am
by jmentor201016
Ok. It worked. Thank you so much!
In response to your question: nothing changed. At least I didn't change anything. I do know the weird thing about it was when it worked with the older driver, it was seen as GPIB1 instead of GPIB0.

Re: Labview doesn't recognize instrument

Posted: July 9th, 2018, 10:53 am
by Stuart M
Quite welcome.
Glad to get you working.
If things work in NI-VISA Interactive control, they should also work with LabVIEW-32 bit.
GPIB1 or GPIB0 should both work with both products.