Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

TestScript Builder will not connect to older 3706 via USB

Use this forum for questions about Keithley Test Script Builder software.
Post Reply
eoscarson
Posts: 1
Joined: May 21st, 2015, 5:12 am
Country: United States

TestScript Builder will not connect to older 3706 via USB

Post by eoscarson » May 21st, 2015, 5:18 am

I have an older (about 5 years old) 3706 switch/dmm that I am trying to use with the Test Script Builder via USB.
Serial number is #01241847, firmware in the unit is 01.31a.

The device manager in Windows 7 sees the device as a USB Test and Measurement Device.

The instrument shows up in the Test Script Builder Instrument Console as USB0::0x05E6::0x3706::01241847::INSTR.

When I try to connect the 3706 shows errors -285 followed by -420 on the display but seems to be still in remote mode after as the front panel buttons do not function.

The details of the failure on the Test Script Builder dialog are listed below:

---------------------------------------------------------------------------------------------------------------

Failed to open instrument.

VISA reports:
Timeout expired before operation completed.
KeithleyRemoteIO.VISAException: Timeout expired before operation completed.
at KeithleyRemoteIO.TspVisaInstrument.ThrowIfError(Int32 result, String location)
at KeithleyRemoteIO.TspVisaInstrument.Connect()
at KeithleyRemoteIO.TspVisaInstrument.Start(String resourceName, StringDictionary optionStrings)
at KeithleyRemoteIO.TspVisa.Initialize(String resourceName, Boolean idQuery, Boolean reset, StringDictionary optionStrings)
at KeithleyTSPLib.TspClassDriver.Initialize(String ResourceName, Boolean IdQuery, Boolean Reset, String OptionString)
at KeithleyTSPLib.KeithleyTSP.Initialize(String ResourceName, Boolean IdQuery, Boolean Reset, String OptionString)
at com.keithley.KeithleyTSPLib.KeithleyTSP.Java_com_keithley_KeithleyTSPLib_KeithleyTSP_Initialize(IntPtr pEnv, IntPtr pObj1, IntPtr pStr2, Boolean arg3, Boolean arg4, IntPtr pStr5)

-----------------------------------------------------------------------------------------------------------------

Any ideas on this, do I have to update firmware in the 3706??

Thank you

ed

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: TestScript Builder will not connect to older 3706 via US

Post by Stuart M » May 21st, 2015, 12:32 pm

According to section 6 of the release notes for TestScriptBuilder:
Minimum Firmware Version Recommended to Run Scripts for Model 3706 is 1.41.
(also note that script execution will work, but script debugging is not supported).

It looks like you need to upgrade both the firmware and the OS:

Series 3700 Firmware and O/S V1.41c
http://www.keithley.com/support/data?asset=55758

Note: Carefully read the Version 1.41 installation notes before upgrading your Series 3700.

Post Reply

Return to “Test Script Builder”

Who is online

Users browsing this forum: No registered users and 2 guests