Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

NI-Max with KUSB-488B Not Showing The GPIB Devices

Post Reply
OrStudent
Posts: 9
Joined: August 4th, 2016, 7:58 am
Country: Israel

NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by OrStudent » August 4th, 2016, 8:11 am

I would like to describe the problem and steps made ​​to try to fix the problem without success.

I using Keithley KUSB-488B Device. We installed the latest version of the existing site http://www.tek.com/download - KI-488_Driver_Version_3.12.1.
My operating system: Win 7, 64bit.
installed KI-488_v3.12.1\NI Command Compatible Driver. Because I want to use the system interfaces with the software labview.

The Problem: Ni - Max - Not showing the GPIB Devices and
Screen shot of Ni - Max software:
Image
According to Ni-Visa > Visa Interactive Control: can see the GPIB instrument Resources. When you move the mouse over one of the devices noted that message: GPIB0 (unknown GPIB board).
Image
According GPIB0::12::INSTR(Keithley 6221 DC and AC Current Source) option: can sending and receiving data via Input/Output Option, work fine.
Image
According Keithley GPIB Configuration Utility can see GPIB Devices.
Image
According Control Panel > System > Device Manager: have Keithley KUSB-488B.
Image
According Keithley 622x LV 2009 Labview Project(driver for device) downloaded from NI.com.
Image
The error message i received: Error -1073807343 occurred at VISA Open in Keithley 622x.lvlib:Initialize.vi->Keithley 622x.lvlib:KE622x -- Setup DC Current Source Example.vi
Image
the same project when i tryed to run using NI GPIB-USB-HS (when i installed his driver) work fine without any error and can see the GPIB Device in NI Max.


I tryed follow that guide:
viewtopic.php?t=3504

I would do the following:
Check your c:\windows\system32\gpib32.dll file properties and see what the company and file version is....if National Instruments, for instance, then that would explain your problem.
In all events, try the following:
1. Uninstall NI-488.2 (if present). Usually this comes along when you installed NI-VISA.
To check and remove go to control panel -> add/remove programs
Look under National Instruments Software, click on change/remove and look for NI-488.2.
If present, please uninstall it.
2. Uninstall any Keithley KUSB-488A & KUSB-488B drivers
3. Remove any gpib-32.dll files from c:\windows\system32\ folder
4. Reboot system
5. Download and install the latest KUSB-488A or KUSB-488B driver from Keithley's website which is appropriate for your hardware. It is possible you have older drivers. ...btw...which device do you have??
6. After driver is installed, connect your KUSB interface and allow the device to be reconized.
If successful, the device should appear in your control panel -> system -> device manager listed as a GPIB Interface.


The guide does not solve the problem.
Asking for your help on the subject in order to solve the problem.
Or El-Maleh, Student Final Project at Ariel University

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by Stuart M » August 4th, 2016, 10:33 am

NI Max will only show NI devices.
Thus, the KUSB-488B will not appear in NI Max's list of GPIB devices.
It will appear in NI VISA Interactive Control, as you have noticed...

As for LabVIEW...are you using LabVIEW 64-bit or 32-bit?
If you are working with NI GPIB-USB-HS, I would stay with what works for you...

OrStudent
Posts: 9
Joined: August 4th, 2016, 7:58 am
Country: Israel

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by OrStudent » August 4th, 2016, 10:48 am

Labview 64bit.
work fine with NI GPIB-USB-HS. but i need fix your device.

The first product - Your product belongs to which I am doing the project.
The second product (NI GPIB-USB-HS) is not mine , I borrowed it for testing


edit: i saw same problem in that topic: viewtopic.php?f=83&t=120280.
so i think, have a problem in your product or please help to fix it.

OrStudent
Posts: 9
Joined: August 4th, 2016, 7:58 am
Country: Israel

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by OrStudent » August 4th, 2016, 11:50 am

can see more command in http://forums.ni.com/t5/Instrument-Cont ... lse#M72952

I do not understand what problem can occur for several reasons in my opinion:
1) External driver is required link between GPIB that Not created by NI. to install that device in NI Max.
2) Hardware malfunction in Keithley KUSB-488B.
3) the driver does not support my particular operating system Notwithstanding the support as advertised.

I'm trying to figure out the source of the problem and repair it so that I can start working on my final project , of course, also published at the company 's competitor .

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by Stuart M » August 4th, 2016, 12:13 pm

There is nothing broken and there is nothing to fix.
For LabVIEW (64-bit version only), NI only supports NI GPIB devices.

In the 64-bit world, you can install multiple VISAs and each can control different interfaces.
IDownload and install Tek VISA (no need to uninstall anything)
http://www.tek.com/oscilloscope/tds210-software-0
After Tek VISA is installed, set it to control your GPIB device as follows:
Open NI MAX and select My System > Software > NI-VISA.
Click on the VISA Options tab and then click on the Conflict Manager.
Select your Interface Type (GPIB0::12::INSTR) and then select the Chosen VISA (change from NI to Tek).

OrStudent
Posts: 9
Joined: August 4th, 2016, 7:58 am
Country: Israel

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by OrStudent » August 4th, 2016, 12:27 pm

I will try it tomorrow when I get to the lab.

In your opinion, after the last action by your guide to solve the problem and be able to work with the same Labview program that You provided (Keithley 622x.lvlib )?

My project should eventually take over 4 different devices (3 of your) GPIB communication protocol. This proposed change will now only for working with one device, or what should I do to be able to work with 4 device connected by GPIB.
Thanks in advance.

OrStudent
Posts: 9
Joined: August 4th, 2016, 7:58 am
Country: Israel

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by OrStudent » August 6th, 2016, 11:00 am

I tried your advice last Friday , but this method does not resolve the problem ( is still the same error trying to run the program).

I will try to install on another computer with 32bit operating system. and Labview 32bit I hope that will work.

OrStudent
Posts: 9
Joined: August 4th, 2016, 7:58 am
Country: Israel

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by OrStudent » August 7th, 2016, 4:24 am

work great via Labview 32Bit using same system operator.

Stuart M
Keithley
Keithley
Posts: 418
Joined: September 22nd, 2010, 1:42 pm
Country: United States

Re: NI-Max with KUSB-488B Not Showing The GPIB Devices

Post by Stuart M » August 8th, 2016, 6:45 am

That's great to hear.
Most do use LabVIEW 32-bit.
Glad to hear that you can now get back to working on your project.
Best regards...

Post Reply

Return to “LabView Drivers”

Who is online

Users browsing this forum: Google [Bot] and 1 guest