Tektronix Technical Forums are maintained by community involvement. Feel free to post questions or respond to questions by other members. Should you require a time-sensitive answer, please contact your local Tektronix support center here.

TEK TDS724A, Channel 1 Dead but tests pass ?!?!?

Questions in this forum area are community supported. Tektronix does not regularly monitor posts in this area.
Post Reply
jasonru405
Posts: 1
Joined: May 25th, 2018, 1:32 am
Country: United Kingdom

TEK TDS724A, Channel 1 Dead but tests pass ?!?!?

Post by jasonru405 » May 26th, 2018, 2:27 am

Hello, I have this very peculiar problem, my freshly acquired TDS724A seem to pass all the tests BUT the Chan. 1 is totally inert :(, no reaction on input.
How could this be possible, bad relay, shortened input protector, sinister baddie caps or what ?
Any hint or where to start is greatly appreciated.

Also, is it worth opening it and checking the capacitors, is this series one of bag caps, the actual model and serial num is: B010479 , Instrument TDS724A, firmware v4.1e

I have the options: 13, 1F, 2F but no 1M or 2M :cry: , could the option 1M be activated somehow ?

Any suggestions about the fw, is there an upgraded firmware and is worth upgrading ?

And finally I want to do a general cleaning and maintenance, including inspection for bad caps and whatever is known to fail on this model, any suggestions please ?

I doesn't matter if it requires patience, nimble hands, soldering skills or good tools, I have them all ;) and this will be my main scope so I want to restore the dead channel and give it my full attention and love :).

Also, I realize that good probes are f..ing expensive, but for a poor hobbyist less performant but cheap probes may be OK.
Anyone has a source of reliable 3party compatible probes ?

Many thanks for your kind help and pointers to related forum posts and info sources, also sorry for the barrage of questions but I'm excited to have my first Tek :D

strick
Posts: 114
Joined: March 22nd, 2016, 11:23 am
Country: United States

Re: TEK TDS724A, Channel 1 Dead but tests pass ?!?!?

Post by strick » May 26th, 2018, 8:04 am

Jasonru405,
If your scope has any of the suspected caps at all, they will be on the CPU board (top board), the front panel and option 13 board. Yes, you should check them. If you see anything that looks like a stain around one of the caps, remove them all using the procedures elsewhere in the forum. Then you need to replace them with low ESR electrolytic caps. Don't use the same type SMCs. If you can't find the procedures in the forum, send me a PM and I'll shoot you directions.

Your attenuators are directly mounted to the acquisition board. The path to the attenuators is really only checked well with SPC. If it fails, then you know you probably have a relay that is sticky (too much resistance) or the relay has stopped operating altogether. You can manually check the relays by switching the voltage from 1 to 2 Volts and from 100 to 200 mV.

If SPC passes then the internal check of the board and attenuators is generally good, but you may have a disconnect between the attenuator source input and the bnc center. I've seen that before.

If you intend to fix it yourself, be very careful of static precautions as it's very easy to zap the memory chips on the acquisition board.

I would not mess with the bottom attenuator board without really good instructions. Again, proper instructions are very detailed and not for the timid or you risk turning your scope into a brick. Happy to discuss in detail, but not in a general post.

:) Strick

Post Reply

Return to “Other or Discontinued Oscilloscopes”

Who is online

Users browsing this forum: No registered users and 4 guests